How to change audio bitrate?

Hi, I’m running Manjaro XFCE and trying to get Valkyria Chronicles on steam working right.
I’m experiencing a bug with audio popping, that appears to happen to windows users as well, with the prescribed fix of:

“1) some sound rates are not supported, sound settings in Windows should be 24 bit, 48000Hz = proper sound instead of squeaks”

How would I go about changing the audio settings to these? Looking through the Arch pulseaudio page didn’t seem to help.
And you have too look for default-sample-rate
All inside /etc/pulse/daemon.conf
You have to restart the daemon after modifying it. From terminal:
pulseaudio -k

If that works, then you can make use of that file inside ~/.pulse/daemon.conf so the next update is not overwriting your changes.

Archwiki has a section about the PulseAudio configuration file etc/pulse/daemon.conf with a short explanation about some configuration settings you need to change

as suggested, make the changes in home folder so the default settings are available as a backup

I suggest you add these 4 settings:

# ~/.config/pulse/daemon.conf
flat-volumes = no   
resample-method = speex-float-3
default-sample-format = s24le
default-sample-rate = 48000

flat-volumes=no is a setting from the default system configuration that needs to be included here too

default-sample-format = s24le and default-sample-rate = 48000 will give you the 24bit 48000Hz audio that your game wants

resample-method = speex-float-3 is to turn up the quality for resampling
(this is optional but it does improve resampled sound quality)

If you need to check if PulseAudio has found the new configuration and is using the correct settings

pulseaudio --dump-conf

A question about this: if I create a ~/.config/pulse/daemon.conf to overwrite /etc/pulse/daemnon.conf - does this daemon.conf have to contain the complete lines of /etc/pulse/deamon.conf + changes or only the changes as a supplement to etc/deamon.conf?

~/.config/pulse/daemon.conf replaces /etc/pulse/daemon.conf completely

most of the settings in /etc/pulse/daemon.conf are deactivated (with ; at start of each line)
except for flat-volumes=no that has to be copied to the home folder

When the next version of PulseAudio v14 is released the default flat-volumes=yes is due to be changed and it will not be needed in home folder configuration

1 Like

thx :wink:

1 Like

Thanks for the tips and settings guys, succesfully edited daemon.conf as well. Game still not working as desired but that’s a seperate issue to Manjaro.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.