How to auto mount external shared folders


#1

I’m trying to get a shared folder to mount at boot. I’ve got it to mount successfully through the command line, and I’ve edited my fstab file to add the following;

//{my external computer's LAN ip}/{my shared folder name} /home/{my mount folder} 
cifs credentials={a file in which my username and password are written},
iocharset=utf8,gid={my gid},uid={my uid},file_mode=0777,dir_mode=0777 0 0

This is all on one line, I’ve just split it to make it easier to read.

sudo mount -a mounts the shared folder without any problems.

The log after boot just says that the mount failed and the only other unit which failed was NetworkManager-wait-online.service
which sounds suspiciously like it might be to blame, but I’m not sure what to do from here.


#2

Check this thread don’t know if it helps but maybe some hints.


#3

Sounds very interesting, but an application search for ‘Disk Tool’ comes up blank in the repository, so I don’t know what utility he’s using.


#4

start menu>applications>disks is what he means. Video


#5

Yeah, that’s what I thought he meant. I have no such application. Nothing called ‘Disks’ under utilities, nothing in response to a search for ‘Disks’ in the Application Launcher, and no package called ‘Disks’ or anything like it in the repository. So I guess I’m looking for the Manjaro equivalent of ‘Disks’.


#6

gnome-disks :wink:


#7

Thanks. I’ve found the utility he’s using now. Unfortunately, I can’t make out how it’s supposed to help automount shared folders (if at all) as it only seems to have automount options for physical disk partitions.


#8

I googled this for ‘startup script’


#9

I will give it a try, thanks, but I don’t understand the difference between a startup script and the entry in the fstab, Isn’t the fstab supposed to be looked at during startup?

Just as a thought, does the startup routine look up drives in the fstab before starting any network managing services? If so, then that might explain why It’s not working, it’s looking to mount a network drive before having any way of detecting what’s on the network. Is it possible to make the startup script happen after the network has been discovered, is that the difference?


#10

I’ve solved the problem (I think) - All that was needed was to add

noauto,x-systemd.automount,x-systemd.device-timeout=30,_netdev

to the parameters in my fstab entry, and now it seems to mount on demand.

Full instructions here