How i can delete the Manjaro from my drive to reinstall the windows 11?

Hi Guys ! I have installed my Manjaro OS on dual boot alongside the Windows 11, but during the installation, I accidentally deleted the windows EFI partition. I tried all possible ways to repair it from Windows 11 bootable USB, but it didn’t work for me, then I deleted the Windows 11 from the drive completely during the Manjaro installation. Now I want to install the Windows 11 and then alongside Windows 11. I want to install Manjaro, but I don’t know how to first delete the Manjaro from my drive because I tried to install the Windows 11. Now, It says there isn’t any hard drive attached on the installation process.

and is not windows detected in your grub menu? run this command:
sudo update-grub and post the formated output from the command here

Nice to hear again from you brahma…

sudo update-grub
[sudo] password for adnannaeem: 
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.15-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.15-x86_64.img
Found initrd fallback image: /boot/initramfs-5.15-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.10-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.10-x86_64.img
Found initrd fallback image: /boot/initramfs-5.10-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

thank you … so your windows is not being detected … but you can restore your windows bootloader, search guides on the internet on how to do it … because the way you want to do it is too complicated…

No, No Listen, Last night when you said that my system is consuming RAM due to Snap packages. I deleted all the packages, but it didn’t work effectively so, I decided to reinstall the Manjaro my Windows 11 was working fine till last night but during the installation. I deleted the EFI partition of Windows 11 then I tried hard to fix it, but I failed, then I deleted the Windows 11 from my drive.
Now, I come to know that I can’t install Windows 11 alongside Linux, but I can install Linux alongside windows

Now, There’s only Manjaro in my hard drive. I want to clean my hard drive with Manjaro so, there’s no OS left. Then I’ll install Windows 11 and alongside Windows 11 I’ll install Manjaro.

oh i see … so how many partitions do you have right now? or you just install manjaro on the whole disk?

Basically, I have 3 partitions. 1 was with win 11 and 1 of windows data and only there was single partition for Manjaro.
Now, My both windows partitions are NTFS and 1 Manjaro partition

so there shouldnt be a problem to install windows on the 1 partition

Yeah, you are right, but when I go to the partition format window of Windows 11 or 10 process, it shows you don’t have a drive to install the windows.
I have read too many articles and watched video how to again install Windows 11 but not a single solution worked for me.

so just completely delete the partition on which you want to install windows, dont format it, just delete it, and then boot windows usb, and it should detect it

So, I guess if this solution works then I also have to delete the partition of my windows partition data, right? Then both partitions will show on the windows side ?

what do you mean with windows data? you mean pictures, music, documets … etc? or just windows and program settings?

I mean i have 2 partitions 1 with windows 11 and other with windows games and University data right and these both partitions was worked on windows side before and i was not able to use them on manjaro side but now i can use these 2 partitions also on majaro side …

dont delete the data partition, only delete 1 partiton and install windows onto it

1 Like

Okay Sure ! I’ll be right back in a few minutes after implementing this great test … LOL

It shows a window of ( Load Driver )
(Load Driver) No device drivers were found. Make sure that the installation media contains the correct drivers, then click OK.

instead of clicking on load driver, try clicking next…

Next button was disabled

try this guide, hopefully it will work

List volume
I tried these two command on the terminal it shows only my USB storage not my SSD drive.