How do you get to a libreoffice file in chroot/LiveISO?

Does Anyone know how to get these file type I’m talking about. I"m doing this because I have to reinstall my Manjaro system. I can’t get to these files In order to back them up.

In theory it should be easy. Well, relatively easy, anyway.

To start off you’ll have to make sure the drive/partition is mounted. For that you need to know the drive name and partition number of your partition. For example sda1 or /dev/nvme0n1p2.

This can be foubd out with the blkid command


The command should return a list similar to this:

/dev/nvme0n1p3: UUID="D563-DAB7" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="0653a05b-0f22-f64c-a283-7cc0dcb83551"
/dev/sda1: LABEL="5TB" UUID="953836d8-e355-4c6d-ac1a-0914b8414f50" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="7a05b57a-5368-c647-baa3-410f462004a6"

(Mine is a lot longer, I just grabbed an excerpt as an example. Also note that mine is alreeady mounted at /mnt/5TB)

From that I can discover that my 5TB s partition name and number is **sda1**. I can also see that it's of filesystem type ext4`. That is very important.

Armed with this knowledge, when in the Live CD environment, you can create a mount point for it. For example:

mkdir ~/5TB

(The ~ character is a Linux alias for your home directory. So that command would create a directory 5TB in your home directory.

If all’s well up to here, you can go ahead and mount the drive. According to the information gathered above, the command would be:

mount -t ext4 /dev/sda1 ~/5TB

This command will mount filesystem type (-t) of ext4 on partition /dev/sda1 on mount point ~/5TB.

You can them browse the files as normal on ~/5TB.

See [root tip] Use systemd to mount ANY device for more information.

Remember that this isn’t permanent. Any changes made to Manjaro itself will not survive a reboot and you’ll have to do it over again on the next startup.

If you simply boot your system from USB - the same you’ll use to later install the new system - open the file manager and look on the left side for something like “File System” or “Computer” … whatever the name is.
Your hard drive should definitely be visible - and if you click it will be “mounted” and you can navigate to your files to back them up.

When I copy paste blkid I get [manjaro@manjaro ~]$ again. I’m I doing this wrong. Info might be needed for this. I loaded the liveISO without updating it. I did it Konsole and Yakuake. Is It not working because of what thing I select in the boot menu. To explain the last one I get three options when I choose boot the in the liveISO. I’m going to see the other two.

I’m also using kde If that helps.

to get into chroot I use the command manjaro-chroot -a. after that I usealy get this:

[manjaro@manjaro ~]$ manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
==> Detected systems:
 --> 0) ManjaroLinux
==> Select system to mount [0-0] :

I then press 0 to get into chroot. I then get the following:

==> Mounting (ManjaroLinux) [/dev/nvme0n1p3]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
[manjaro /]# 

Is this right.

blkid should return something similar to this:

/dev/nvme0n1p1: UUID="1b3f894f-5481-4241-ace5-c129a0cdb412" TYPE="swap" PARTUUID="30f1cded-fe63-be47-9fe7-e2bdf635f38f"
/dev/nvme0n1p2: UUID="9a26c8d0-43f4-44ad-a7d3-861d6f6cdbfa" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="b84f55b3-2488-a14c-9c4a-6acd385f2db6"
/dev/nvme0n1p3: UUID="D563-DAB7" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="0653a05b-0f22-f64c-a283-7cc0dcb83551"
/dev/sda1: LABEL="5TB" UUID="953836d8-e355-4c6d-ac1a-0914b8414f50" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="7a05b57a-5368-c647-baa3-410f462004a6"
/dev/sdb1: LABEL="4TB" UUID="c47c5a52-db30-4aef-bcbc-af35b7b021fd" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="32f8a311-a601-ed4c-96d3-0d4cf6e6bd04"
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/loop4: TYPE="squashfs"
/dev/loop5: TYPE="squashfs"

(It won’t match exactly, because this is from mine, but it should be similar.)

In this listing I can see the following:

  • /dev/nvme0n1p2: The path of my main NVMe system drive. I can know this because it’s the only partition not on the 4TB or 5TB drives that are formatted ext4.
  • /dev/nvme0n1p1: My swap space, as can be seen in the type key.
  • Various loopback devices (/dev/loop*). Which I’m guessing is from having some .AppImage files running.

Armed with that information (except the loopback devices, obviously) it’s possible to identify which device to mount to get the files off.

Yes, that seems right to me!

what is desktopfs-pkgs.txt I get when I type in ls

Never seen or used it before, so I did a quick google. It seems it is a list of packages installed on your computer.

Indeed, the file is present on my computer as well, and it does seem to contain a list of everything installed on my computer. So I think you have to leave it alone on the Live ISO. There’ll be MANY unknown files there.

Do not worry about them. They have to be present to make the system work correctly.

Don’t you think this should work?
(third post here)

The harddrive with the data on it, the one he also wants to install to later, should be accessible simply from the file manager, no?
It is for me, every time, from any live medium.
All he presumably wants to do is accessing his data?

Did you even try that @thisonesforum ?

It should, yes.

I over complicate things like this. Mainly because I don’t ask here for assistance unless I’ve tried everything and am really desperate. So the easy, logical method has already been tried and discarded when I ask. So when I offer help/assistance, I automatically, and sometimes mistakenly assume the easy, logical way is a no-go.

Yeah, I know it’s a mistake on my end.

No worries.
I just wonder whether he overlooked my post and didn’t even try, although that, to me, is the intuitive thing and the very first thing I’d try.

otoh … I have a certain suspicion
let’s wait and see …

Same, man! Thanks for asking, for making sure.

I checked Dolphin And everything I clicked on was blank. Did I do something wrong, or do I have to something else as well.

I did yours first anyway.

That is hard to believe - since chroot seems to work, the device is clearly there and is used and usable.
… anyway

boot the iso
open terminal


will list all the devices - including your harddisk


will be among the listed items - lets assume that this is the drive containing your data

sudo mount /dev/nvme0n1p3 /mnt

will mount that drive to the /mnt directory of the currently running system

cd /mnt

will show you the directory structure of your drive
including your /home/$username directory where your files are

… and if you now still cannot open and use Dolphin to navigate to /mnt and beyond
I cannot help you.

I did that and every command seems to work, but what do you do next. manjaro@manjaro seems weird because that is not the name of my pc.

back up your files?
using the filemanager (Dolphin)?
I’m done here.
Either you are trolling
or you have a problem with a really short attention span,
coupled with no interest (or maybe ability) to help yourself,
that I do not wish to deal with anymore.

Good luck!

This is not your forum @thisonesforum