How Do I Upgrade - Linux Kernel?

I tried to upgrade to a different Linux Kernel on my Manjaro GNOME. I install version 5.14 also 5.10

(Linux513 is now EOL right?) I used the Manjaro Settings Manager GUI to install the two new Kernel.

Not sure why It’s still running 5.13 even after every reboot. My new kernels also don’t show in the GRUB advanced menu for selection.

What am I doing wrong? I need some advice on this.

mhwd-kernel -li
Currently running: 5.13.19-2-MANJARO (linux513)
The following kernels are installed in your system:
   * linux510
   * linux513
   * linux514

Do I need to provide more info? What would be relevant and useful?

1 Like

Tap Shift or Esc during boot to make sure to get a GRUB menu.
FRom there Select your preferred kernel.
(This may be under ‘advanced’)
After you are sure you are booted into your preferred kernel
( uname -a )
Then you may proceed to delete the old kernels.

1 Like

Am able to get into the GRUB menu.
Under ‘advanced’ only one Kernel is on the list though. The old one.

I am using full disk encryption, so I tap Shift after my password decrypts. To access GRUB menu.

uname -a
Linux DESKTOP-03 5.13.19-2-MANJARO #1 SMP PREEMPT Sun Sep 19 21:31:53 UTC 2021 x86_64 GNU/Linux

It should have done it automatically, but could you type sudo update-grub and ensure the additional kernels are well listed in the newly generated grub config?

After that, it should be available at reboot in Grub advanced menu.

1 Like

Do you have a file /boot/grub/ and if so what is its content?

The .new is created whenever you have a typo in any of the grub files used to create grub.cfg. I once forgot a closing } in 40_custom. It then showed error as last line which did not help much, but it may show error line. Also could be in /etc/default/grub, if line not correct.

oldfred - Nov 30 '19 at 17:34

What is the output of sudo update-grub?

Ultimate question is your system up to date? sudo pacman -Syyu

1 Like

My system was up to date @omano - and more updates were available this morning 2021-10-16
I installed those also.

@Falav I did a sudo update-grub Then restart my computer. No new kernels listed in the GRUB menu.

I paste the output below, and noticed the following line:

/usr/bin/grub-probe: error: unknown filesystem.

When I installed manjaro I chose the F2FS (Flash-Friendly File System)
Maybe F2FS is somehow related.

> sudo update-grub
> Generating grub configuration file ...
> Found linux image: /boot/vmlinuz-5.14-x86_64
> Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.14-x86_64.img
> /usr/bin/grub-probe: error: unknown filesystem.
> Found initrd fallback image: /boot/initramfs-5.14-x86_64-fallback.img
> Found linux image: /boot/vmlinuz-5.13-x86_64
> Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.13-x86_64.img
> Found initrd fallback image: /boot/initramfs-5.13-x86_64-fallback.img
> Found linux image: /boot/vmlinuz-5.10-x86_64
> Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.10-x86_64.img
> Found initrd fallback image: /boot/initramfs-5.10-x86_64-fallback.img
> Warning: os-prober will be executed to detect other bootable partitions.
> Its output will be used to detect bootable binaries on them and create new boot entries.
> Adding boot menu entry for UEFI Firmware Settings ...

if you can answer that it could help. I predict it is the case regarding the symptoms, and the recent information you posted.

1 Like

The file exists at that location,


Though I am reluctant to post it’s content here in a public forum. Contains numbers and stuff, perhaps related to disk encryption. Should I remove/censor anything before posting? I am unsure and slightly paranoid.

It does not contain any secrets.


Apparently if this file exist, it is because something broke during the creation of the grub.cfg file, so it doesn’t update it and stops.

1 Like

I paste the contents of my /boot/grub/

The numbers that concerned me have been replaced with zeros.

Seems like it stops/breaks at ### BEGIN /etc/grub.d/41_snapshots-btrfs ###

Are you sure you are up to date? There was an issue with grub-btrfs that looked like exactly like that. This was fixed last week or so.

sudo pacman-mirrors --country Global && sudo pacman -Syyu

Are you using a BTRFS file system?

1 Like

I selected the F2FS (Flash-Friendly File System) when I installed Manjaro. Thought it would be a good choice for my Samsung SSD - Not using the BTRFS file system at this time.

Will check to see if my system is up to date. When I get another chance tomorrow.

I guess you could remove the package grub-btrfs it seems it is installed but if you don’t use BTRFS file system you shouldn’t need it.

1 Like

That is the first thing todo when you experience any problem.
grub-btrfs had a bug resulting in the problem you’re describing - but it’s been fixed:

1 Like

Update - I sort of solved my Linux Kernel problem. The lazy way though, by reinstalling Manjaro. This time I chose the EXT4 file system, instead of F2FS

Not sure what caused original issue. I suspect the absence of grub-f2fs package is somehow responsible. It’s available in the AUR, but is out-of-date. Be careful because I really don’t know.

Choosing The Best Linux Filesystem 2021 - Make Tech Easier

You don’t need it and it won’t do anything for a OS on a non BTRFS system.

1 Like

Package grub-f2fs in AUR is very dated

First Submitted: 2016-05-08 18:53
Last Updated: 2016-05-08 18:57

Flagged out-of-date (2017-04-19)

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.