How do I switch from my onboard (integrated) graphics to my nvidia graphics card?

Hey,
I have recently moved from windows to Manjaro and have been stuck for the last couple hours trying to work out why I was getting my fps capped at 60 on CSGO. As the title suggests it was because Manjaro bas been using my CPU's graphics. Here's my glxinfo | grep OpenGL:

OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) HD Graphics 630 (KBL GT2)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 20.0.6
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.0.6
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.0.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

and part of my neofetch:

                               CPU: Intel i5-7300HQ (4) @ 3.500GHz 
                               GPU: NVIDIA GeForce GTX 1050 Mobile 
                               GPU: Intel HD Graphics 630 
                               Memory: 2428MiB / 7848MiB 

Thanks

Welcome to the forum! :beers:

Perhaps the following will help you on your way... :arrow_down:

2 Likes

Last time I had a problem along the lines of switching it involved needing to install vulcan and similar packages (dvxk? not sure). Not sure if this will help as I use AMD and found some games were not using the Graphics card.

Hey, I'm only trying to help the OP on their way. I don't have nVidia graphics either. :wink:

1 Like

Sorry! I meant to reply directly to the OP, I thought your post was completely on point.

1 Like

https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards

Namely this section for free open graphics:
https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards#Dual_GPU

But you probably want this one for proprietary nvidia:
https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards#Nvidia_Optimus

And most things are capped at 60 fps because ..
well, unless your monitor can handle 60, the extra fps isnt even going to be output.
and your eyes .. probably cant tell much difference. Apparently trained pilots can maybe get hints (as in detect some light and make guesses) at up to a rate of 255 FPS or so. but most likely you cant really notice. Eh .. its a long topic. Do some research: https://www.pcgamer.com/how-many-frames-per-second-can-the-human-eye-really-see/

But on that note - you probably have to disable vsync/vblank to get rid of the 60fps cap
(it has nothing to do with using one driver over the other or which card is used)

examples on disabling vsync:
https://wiki.archlinux.org/index.php/Intel_graphics#Disable_Vertical_Synchronization_(VSYNC)
https://wiki.archlinux.org/index.php/Bumblebee#Primusrun_mouse_delay_(disable_VSYNC)

1 Like

Thank you everyone for such fast and helpful replies,

I fixed my drivers and setup optimus-manager-qt using this guide:
https://forum.manjaro.org/t/guide-install-and-configure-optimus-manager-for-hybrid-gpu-setups-intel-nvidia/92196
which was literally perfect.
Thanks once again to everyone who helped me, it's great to be joining such a positive and helppful community

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by