How do I share folders on the network with Samba for guest access?

Hi, I have used other distros with the KDE/Plasma desktop, but have been having problems with the latest updates of those to do a simple file sharing on my network, so I decided to give Manjaro a shot. I am on the xfce edition.

This is a fresh install, just updated after install.

I have looked at the various wiki and man pages, installed the default manjaro-samba-settings, and am hitting a wall. Rather like I was on Mageia 7, and others. I’m clearly missing something, but don’t know what.

What I want to do, is share a series of sub-directories under my home folder, via samba, to the network, so that no user or password is required (akin to the now deprecated ‘share’ method of old).

My understanding is that to do this, the smb.conf has a number of lines of usershare set, and then the appropriate smb filesharing extension for the file manager should be the easiest and fastest way yo do this. After following the directions to do so, I end up with two problems:

  1. when I attempt to share the folders, I get the following error:
    “Cannot modify share: ‘net usershare’ returned error 255: net usershare add: cannot convert “Everyone” to a SID. (Access Denied) A process has requested access to an object but has not been granted access rights…”

Problem is, I have no idea what I need to grant rights to in order to give access.

  1. Once I tried to enable this share, now the machine in question cannot see the rest of the network (neither the old Mageia 5 server with share level samba shares, or the windows machines).

I’ve spent over a week futzing with just trying to do simple shares on the latest Mageia, with less luck. I seemed to be making more progress with Manjaro - at least the machine APPEARS on the network, just not any of it’s shares.

I’m perfectly happy digging around in files, and using the command-line, I’ve been using computers since MS-DOS 5. But I cannot find any clear answers to why the samba shares aren’t working.

Any help is greatly appreciated.

Update: I reinstalled from scratch. Installed just the samba settings and file manager appropriate plugins. Rebooted once. And this time, there were no permission or access violations. I have no idea what I did.

The computer still can’t mount the shares from other computers, but one is old, and I’m just going to count that a victory for today.

1 Like

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

P.S. In the future, please mark a solution like this:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.