How do i optimize XRender for KWin

Hi everyone!
Basically, i wanted to use XRender as my default rendering backend. Also cause OpenGL caused me too much trouble, especially when i’m gaming. So i wanted to switch to XRender for ever. But i don’t know why when i enable it all the desktop effects even my blur settings are gone. So i decided to read some articles about that and i find out that KWin is not optimzed for XRender (At least from what i understand). And when i tried to reboot to see if maybe something changes, And indeed anything changes. It gets instead it gets worse than i imagined. Nothing loads, only a blackscreen with nothing except my cursor.

And it probably never will be.
Consider xrender on kwin … unsupported legacy.
Its the very last option if absolutely nothing else works.
There are really only very specific circumstances in which xrender would be the preferred. In almost all cases you probably want to use OpenGL - 3.1 if possible.

1 Like