How do I get my Plex media server running on startup?

Yes it should be, It is a sabotaged SSD which had windows which i have to wipe and setup for just storage, properly, soon.

Well, if it works, then good for you, but I foresee problems with permissions arising soon, because NTFS does not store POSIX file ownership or permissions.

So better would be to include a record for that filesystem — with the proper permissions as a mount option — in /etc/fstab. Something along the lines of… :arrow_down:

UUID=the-UUID-of-the-partition   /run/media/hydra/Storage   ntfs-3g   auto,nofail,uid=1000,gid=1000,utf8,umask=022,defaults   0   0

You can find out the UUID of the filesystem with… :arrow_down:


More information can be found in the tutorial below… :arrow_down:

you can try this

sudo chown -R $USER:$USER /run/media/hydra

reboot and test. if it works remind that it is a dirty-workaround.
the main problem is the ntfs…
the setup as @Aragorn recommends below is the better way but might need some work.

1 Like

I dont mind changing the filesystem, as ive to clean the SSD anyway. Should I? But I noticed it also doesnt see the manjaro partition in the same directory.

sda           8:0    0 465.8G  0 disk 
├─sda1        8:1    0   100M  0 part 
├─sda2        8:2    0    16M  0 part 
├─sda3        8:3    0   1.9G  0 part /run/media/hydra/0a001be9-83af-4bbe-9c23-a4bca902cf61
├─sda4        8:4    0 285.7G  0 part /run/media/hydra/Storage
├─sda5        8:5    0   509M  0 part 
├─sda6        8:6    0 167.5G  0 part /run/media/hydra/Manjaro22
└─sda7        8:7    0    10G  0 part 

Ive attached the partitions of the SSD

YES ! cleaning up the closet is always the best decission.

1 Like

Hii @Hydraknight,

I’d say so. It can only do you good. Get a proper filesystem running.

Shouldn’t be used for anything that is to be permanently mounted. Rather mount it under /mnt. That’s what it’s there for, after all.


followed by:


I actually have no idea how it mounted to /run. Now that I am resetting the SSD, ill make sure its mounted to /mnt.

Should i format the SSD to ext4?

1 Like

Actually, no — /mnt is intended as a temporary mountpoint.

Considering that it’s a filesystem intended as a media server, I would create a mountpoint for it under /srv. On my system here, I use /srv/mmedia for all my multimedia stuff. That way, all user accounts have (read-only) access to it — root has write access, of course.

Time to promote another one of my tutorials… :stuck_out_tongue: :arrow_down:

It’s udisks2, a plug & play subsystem of systemd.

Don’t — see above. :wink:

That’s a good choice. :wink:


That’s news to me. All my partitions are mounted in /mnt/<subdiectory>. Unless you mean directly, in which case yeah, and I’m sorry for the misunderstanding.

1 Like

No, even then still, if you mount something to /mnt directly — which is what /mnt is intended for — then it’ll hide all your other mounts under there, because the subdirectories will no longer be visible.

Read my tutorial(s). :wink:

I intend to use the external ssd to store files from windows as well(I have dual booted). Partition manager says ext4 is linux only. Should i consider any other format like ExFAT?

I’ve done so, but I confess that I might have missed something…

1 Like

this format will be supported by both systems, so if you still need to use windows with it then it’s a good compromise.

if you do so you can install the package “exfat-utils” that you’ll might need some day

1 Like

Create two partitions: one in ext4 and another one in exfat — there are fewer problems with exfat than with ntfs, and GNU/Linux can read and write to exfat.

That way, you can mount the multimedia stuff on the ext4 partition to /srv/mmedia — after creating the mountpoint, of course — and you can mount the exfat partition under your $HOME somewhere.

I just got this error

Error creating file system: Command-line ‘mkfs.exfat -n ‘External Storage’ '/ dev/sda1" exited with non-zero exit status 249:
stdout: °
exFAT format fail!
stderr: ‘input string is too long
*(udisks-error-quark, 0)

How do you suggest I split my 500 gb disk? 350-150? ext4-exfat

your using the partition-manager ? you deleted the existing partition and tried to create a new exfat-partition ? may you tell us in detail what you were doing. the error message without knowing from what application it rised isn’t helpful.

please post the output of

1 Like

Sorry, i am using the gnome-disks-utility application for this. I formatted the entire disk and now am trying to create a new partition.


PATH           PTTYPE PARTTYPE                             FSTYPE PARTTYPENAME
/dev/sda       dos                                                
/dev/sda1      dos    0x83                                        Linux
/dev/nvme0n1   gpt                                                
/dev/nvme0n1p1 gpt    c12a7328-f81f-11d2-ba4b-00a0c93ec93b vfat   EFI System
/dev/nvme0n1p2 gpt    e3c9e316-0b5c-4db8-817d-f92df00215ae        Microsoft reserved
/dev/nvme0n1p3 gpt    ebd0a0a2-b9e5-4433-87c0-68b6b72699c7 ntfs   Microsoft basic data
/dev/nvme0n1p4 gpt    de94bba4-06d1-4d40-a16a-bfd50179d6ac ntfs   Windows recovery environment
/dev/nvme0n1p5 gpt    0fc63daf-8483-4772-8e79-3d69d8477de4 ext4   Linux filesystem

Also, what are these loops? Should they be there?

Use gparted. It’s much better. :wink:

Um, you would normally create the partitions first, and then format them. :wink:

They are just loopback devices in virtual memory, commonly used for mounting things like Snaps or filesystem images.

1 Like

shouldn’t you use gparted ?

attention: if you never used a partition manager in the past then please get some infos about it before using it. there are a lot of helpful basic videos at youtube for example.
gparted should be the choice at gnome

1 Like

Okay that worked. What should be the exfat-ext4 split?