How do I exit out of the window popup "Select an application to open 'x-scheme-handler/lbry"?

This surely has to be a common issue with people. It happens consistently when I click on certain links in web browsers and also did so in my previous installation of Manjaro in April this year. It’s really annoying when it happens because there’s literally no way of closing it at least through normal methods. There is only a “Minimise” and “Maximize” button. I don’t want to close anything in System Monitor related to KDE in case I accidentally close the wrong thing and close the desktop environment or something. I’m pretty sure I know why this popup pops up; it’s because my browser is trying to open a link in an application installed on the computer. But if I don’t have a compatible application for the link to open into, I will get permanently stuck in this window until the next time I restart or shut down.

Follow the instructions and choose an application so the requestor screen doesn’t have to keep popping up asking you to tell it what it needs to do.

Ok. But I don’t have an application to do that. And I shouldn’t be forced to find and download an app just to cross out of it. I should be able to cross off it if I feel that I want to do it later.

Even though I shouldn’t be forced to download an application, I downloaded LBRY which is the app that was needed. It didn’t even pop up in the list of applications, so I can’t click on it to cross off even if I wanted to.

Blame the programmer because he was the one that coded it in, most probably because it was the application that he uses.

From the screenshot - and from what I remember of KDE - it appears that you use Konqueror as your browser.

Is it the same with others?
“Real” browsers? :grin:

can you provide an example - a web page with such a link on it, that triggers your problem?

review ~/.config/mimeapps.list
and perhaps just delete the lines that may contain a reference to that …

Well, you did at some point. Perhaps a LBRY application from the AUR?


I’m using Librewolf (Firefox). It also happens in Brave browser (Chromium). I was trying to open a LBRY link. Here’s an example link lbry://@MGJ#4a/bioshock-remastered-playthrough-part-1#2 . I fixed it by downloading the LBRY application but I didn’t want to have to. When I put the link into the browser, I forgot that you can only view LBRY videos in the application, which I didn’t have.

I did used to have LBRY but I didn’t get it from the AUR. But I used to have this problem before I installed LBRY for the first time. I can’t give you any non-LBRY examples but I also get this window pop up when I click on certain other links and don’t expect that I’m going to need an application to open it. So when the window pops up and I can’t cross out of it, the only options I have is to.

  1. Deal with it and leave it sitting in the task manager bar while getting in the way of things since I’m usually multitasking.
  2. Install the required program that I may not even want on my system. or,
  3. Restart the whole computer to make the window go away.
    I usually end up going with the third option because the window annoys me too much.

Not the link that you gave - the link to a web page or whatever - with the link in it.
I wanted to see for myself what the problem might be.
Your link here just does nothing - it isn’t even a link. Just normal text.

and then there was this:

you can even delete the entire file with no ill consequence but let’s just move it
mv ~/.config/mimeapps.list ~/.config/mimeapps.list-backup

and maybe this helps, too:

Manage file types and download actions in Firefox | Firefox Help

Sorry for taking a while to reply. The link I gave you isn’t exactly a proper link. You paste it into the address bar and it does 1 of 2 things. If you have the LBRY app, it opens the video from the “link” in the LBRY app and the video plays. If you do not have the LBRY app, pasting the text into the address bar causes this “x-scheme-handler/lbry” window to open up and be permanently stuck that way until you either restart the system or install LBRY. Here’s another link example lbry://@Thoughty2#b/why-couldn’t-mother-nature-kill-this-man#b . For me, now that I actually have LBRY installed; whenever I paste the link into the address bar and hit enter, the video correctly opens in the LBRY application. Does it just do nothing at all for you?

I’m not really sure how comfortable I am with removing lines of text from config files. I like to understand for myself what I’m actually deleting rather than doing it blindly.

the command I suggested does not remove or delete anything.
It just moves the file to a different name - it renames it.

Therefore, it will still be there should you indeed need to restore it.

You could just copy it to somewhere - and then delete the original.
Same concept.
You still have the content of the original …

You are uncomfortable because you do not know what the command does -
but by now, you (should) know.

the file will still be there - under the name: mimeapps.list-backup
and is easy to restore … should it be needed
(which it won’t …)

The mv (move) operation is just the equivalent of
copy the file to some other place/name
and then remove/delete the original.
You end up with the file in question … removed
but still have a copy of it to go back.

comfortable or not
do it already :grin:
it can’t be getting any worse than it is now

putting this:
into google
results in an error
… for me

lbry is just not a real thing … not a valid url /protocol … whatever you choose to name it

it does nothing, nothing at all, just an error message

Amazing. It seems to be fixed. I uninstalled LBRY just to test it out again before using the command you gave me and there’s now a cross button where it should be. Maybe one of the devs saw my post and fixed it? Or maybe it was a KDE dev updating KDE and not Manjaro? I don’t know, but I’ve had the issue in Manjaro KDE since I started using Manjaro in April. Now it’s gone so I won’t need to use the command. Thanks for the help. I was going to use the command and see if that fixed it but now that it’s been officially fixed I don’t need to do that.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.