How do i disable vsync for a proton game through the nvidia driver?

Hello manjaro community, i have been attempting to disable vsync to a game through the nvidia driver on Atelier Ryza, which i am running with proton. Sadly the game does not have the option to disable vsync through the setting nor the config file. Is there a way i can disable it through the driver?
Here is what inxi shows about my system:

  Kernel: 5.4.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=ffbe837b-6fd6-46d0-9e6e-6cf0d181e088 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 btusb.enable_autosuspend=n 
  Desktop: KDE Plasma 5.17.5 tk: Qt 5.14.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Gigabyte product: AB350-Gaming 3 v: N/A 
  serial: <filter> 
  Mobo: Gigabyte model: AB350-Gaming 3-CF v: x.x serial: <filter> 
  UEFI [Legacy]: American Megatrends v: F23d date: 04/17/2018 
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 2S 
  serial: <filter> charge: 100% (should be ignored) rechargeable: yes 
  status: Discharging 
CPU:
  Topology: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen 
  family: 17 (23) model-id: 1 stepping: 1 microcode: 8001137 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 76673 
  Speed: 1374 MHz min/max: 1550/3200 MHz boost: enabled Core speeds (MHz): 
  1: 1628 2: 1403 3: 1375 4: 1378 5: 1332 6: 1341 7: 1332 8: 1339 9: 1375 
  10: 1375 11: 1375 12: 1375 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: Gigabyte driver: nvidia 
  v: 430.64 bus ID: 06:00.0 chip ID: 10de:13c2 
  Display: x11 server: X.Org 1.20.7 driver: nvidia compositor: kwin_x11 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 430.64 
  direct render: Yes 
Audio:
  Device-1: NVIDIA GM204 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 06:00.1 chip ID: 10de:0fbb 
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 08:00.3 chip ID: 1022:1457 
  Device-3: C-Media Blue Snowball type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-2:2 chip ID: 0d8c:0005 
  serial: <filter> 
  Sound Server: ALSA v: k5.4.12-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: f000 bus ID: 04:00.0 
  chip ID: 10ec:8168 
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter> 
  IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:
  Local Storage: total: 2.07 TiB used: 301.60 GiB (14.2%) 
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW010T8 size: 953.87 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 002C scheme: MBR 
  ID-2: /dev/sda vendor: Western Digital model: WDS250G2B0A-00SM50 
  size: 232.89 GiB block size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s serial: <filter> rev: 30WD scheme: GPT 
  ID-3: /dev/sdb vendor: Western Digital model: WD10EZEX-08WN4A0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: GPT 
Partition:
  ID-1: / raw size: 953.87 GiB size: 937.90 GiB (98.33%) 
  used: 301.60 GiB (32.2%) fs: ext4 dev: /dev/nvme0n1p1 
Sensors:
  System Temperatures: cpu: 32.9 C mobo: N/A gpu: nvidia temp: 53 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 28% 
Info:
  Processes: 307 Uptime: 41m Memory: 15.65 GiB used: 4.63 GiB (29.6%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: terminator inxi: 3.0.37```
  1. execute nvidia-settings
  2. Go to OpenGL Settings
  3. Disable Sync to VBlank in the screen below:
1 Like

Unfortunately, this did not seem to help. However i added a dxvk.conf file where the game exe is and i added the flag dxgi.syncInterval = 0. This disabled vsync and now the game is running at where it should be. Thanks anyway though.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by