How do I change the permission of an external disk to Readable/Writable?

So I have this Toshiba 1TB External Disk, I have used this disk in Windows 10, so I created a Partition called ¨Linux data¨ and I have made that partition ext4, but for some reason manjaro doesn´t let me write on it, this partition was created in Windows 10 with the minitool partition wizard software, I have tried unmounting and changing some things in the KDE partition manager but then it doesn´t let me mount the partition again. I have also tried changing the fstab file to allow that disk to be readable/Writable but it didn´t work. Is there anyway of changin these settings so I can write in that disk?

This will change the owner to your user, replace /mountpoint with the path to your mountpoint.

sudo chown -R $USER:$USER /mountpoint

You should then be able to write to it.


sudo chown ‘yourname’ ‘pathtodiskpartition’ -R

1 Like

Thank you very much I was trying to fix this for days!

1 Like

You’re welcome. :smiley:

Thank you!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.