How do I change the max volume from 100% to 150%?

I’m guessing you mis-read one of my responses? Or maybe you’re referring to my earlier attempts at looking through the /etc/pulse/* files? Either way I’ve since tried manually creating the ~/pulseaudio-ctl/config (along with it’s parent folder which didn’t exist as I stated earlier) and still no luck

Missread, you’re right!

pulseaudio-ctl does not have a help-file, but it does have a man page: man pulseaudio-ctl

This command should create file ~/.config/pulseaudio-ctl/config and report current volume setting
as a percentage

pulseaudio-ctl current

Software audio servers should not be changing ALSA audio levels, but it can happen

Users should check ALSA settings in alsamixer or amixer -D sysdefault
audio levels in to PulseAudio: pactl list sink-inputs
and out from PulseAudio to ALSA: pactl list sinks

if audio level can be turned up in ALSA, increasing levels above 100% in PulseAudio may not be needed

Tried both variants of the amixer, neither appeared to have an option for setting the threshold, also tried that pulsaudio-ctl current you suggested, likewise no change to the threshold, beggining to think some silly sod thought nobody would ever need to raise the threshold and disabled it in code.

Audio devices in ALSA usually only go to 100%

tried that pulsaudio-ctl current you suggested

Did you delete the comment tag # from #UPPER_THRESHOLD=150 in the config file ?

No diagnostic data or system information makes it difficult to know what is really going on with audio system

It left what I created unmodified and yes I had already removed the comment prefix from the line, I use geany for pretty much all code editing so it’s abundantly clear from the syntax highlighter that’s a setting and not a comment, but for added clarity here’s a copy-paste of the file contents:

# $HOME/.config/pulseaudio-ctl/config

# The default setting is for pulseaudio-ctl to NOT increase to volume level
# above 100 % but Some users may wish exceed this level. If this describes
# your use case, uncomment the UPPER_THRESHOLD variable below setting it to
# the new upper threshold.

If upper threshold in pulseaudio-ctl has been increased

and keyboard shortcut created to increase volume:

/usr/bin/pulseaudio-ctl up

keyboard should be able to increase volume above 100%

Use this command to check current volume level

pactl get-sink-volume @DEFAULT_SINK@

GitHub - graysky2/pulseaudio-ctl: Control pulseaudio volume from the shell or mapped to keyboard shortcuts

That fixed it, had to manually create the setting as it didn’t show up in the keyboard shortcuts dialog (where I created it), added pulseaudio-ctl down for completeness

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.