How do I apply numpad:microsoft X11 options in i3?

I apologize if i3 is unrelated to this issue, but I read that the desktop environment can affect keyboard layouts and I suspect i3 may be part of the issue.

I like to use the numpad home/end + shift to select entire lines, but in most applications, pressing numpad home/end + shift will just put in a number since shift switches back to entering numbers.

From what I’ve read, the numpad:microsoft X11 option should make things work the way I’m used to.

Here’s the output of setxkbmap -query:
rules: evdev
layout: us
options: numpad:microsoft

Here’s the output of localectl -status:
System Locale: LANG=en_US.UTF-8
VC Keymap: us
X11 Layout: us
X11 Variant: ,
X11 Options: numpad:microsoft

Any clue why the numpad:microsoft option doesn’t appear to do anything?


Alright, just found the answer in another thread here. lol
The forum won’t let me link it directly though.

The solution was to add the following to my i3 config.
exec_always --no-startup-id setxkbmap us,us , numpad:microsoft -model logitech_base