How do I add this? Fstab - Use SystemD automount /etc/fstab

Those are options for fstab only…
Systemd-mount has different functionality where those options are translated to…
fe. x-systemd.automount means to create an automount unit for systemd…

Here is another nice read:

You have no swap file or partition.
But you have 32GB of RAM.

@Keruskerfuerst so do i, what’s your point?

I only want to include it because I’m aware it’s an option.

however, the instruction manual instructs you to place it on top.
I therefore wondered, where?

Mount options are related the the mount definition line you use in the fstab so it doesn’t matter if it’s on top middle or bottom, because each line is interpreted separately…
To make it clear those options can not be used alone on their own line…
See: man fstab

1 Like

If the machine runs out of RAM, the computer will freeze.

Yes @Keruskerfuerst and again what is your point in relation to the question in the topic title?:thinking:

I could also just reply with how to make a cake, but it still is not related to the topic

Read it again. It says “at the beginning of the options section”.

Please never post images of text. Please edit your post accordingly so the text you want to provide is text.

did I do it right ?

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=4CF1-D51A                            /boot/efi      vfat    umask=0077 0 2
UUID=be619a77-d895-4540-89af-a2ff1a55907c /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
1 Like


are options
Mount options.

They go where, in the other lines in your file, this is:

as an example - not correct, just for the syntax, this

would become this:

UUID=aabbccdd / ext4 noauto,x-systemd.automount,x-systemd.device-timeout=10 0 1

Try to read up on the structure of the lines in /etc/fstab

1 Like

nevermind. answered above before I finished.

Its for usb I am just trying to read through the wiki so if i should take it out i dont mind

USB drives are not handled by the fstab. You can handle that through your file manager usually.

1 Like

@kisun, The above can be seen as Proof why i said the below:


1 Like

I saw that the computer has no swap file or partition.
The user then will open a thread and will ask, when the computer freezes.

No need to answer problems that are not posted or asked yet, especially in a topic about something totally different…

1 Like


I sent u a message please look

Being proactive is good.

Confusing people when trying to be proactive is bad.



This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.