How can I switch my GPU to a different one?

I want to stop using my NVIDIA GPU and instead use the integrated intel graphics for Linux. I originally thought I could simply uninstall the nvidia drivers, and install the video-linux drivers for intel, but then Xorg doesn't seem to work. What's the proper way for going about this?

Edit: Here is my Xorg log

[manjaro /]# cat /var/log/Xorg.0.log
[    22.691] (--) Log file renamed from "/var/log/Xorg.pid-1046.log" to "/var/log/Xorg.0.log"
[    22.693] 
X.Org X Server 1.20.7
X Protocol Version 11, Revision 0
[    22.693] Build Operating System: Linux Manjaro Linux
[    22.693] Current Operating System: Linux frontear-net 5.4.18-1-MANJARO #1 SMP PREEMPT Thu Feb 6 11:41:30 UTC 2020 x86_64
[    22.693] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=7e8bfcc3-7c7e-4770-bcd6-9c4db17e14dd rw quiet udev.log_priority=3 resume=/dev/disk/by-uuid/dd500cbd-3f1d-4cc4-9193-c82d8982f1ba intel_iommu=on
[    22.693] Build Date: 14 January 2020  01:27:33PM
[    22.693]  
[    22.693] Current version of pixman: 0.38.4
[    22.693]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    22.693] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    22.693] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb 19 10:53:54 2020
[    22.694] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    22.694] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    22.694] (==) No Layout section.  Using the first Screen section.
[    22.694] (==) No screen section available. Using defaults.
[    22.694] (**) |-->Screen "Default Screen Section" (0)
[    22.694] (**) |   |-->Monitor "<default monitor>"
[    22.695] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[    22.695] (==) Automatically adding devices
[    22.695] (==) Automatically enabling devices
[    22.695] (==) Automatically adding GPU devices
[    22.695] (==) Automatically binding GPU devices
[    22.695] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    22.695] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    22.695]    Entry deleted from font path.
[    22.695] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    22.695]    Entry deleted from font path.
[    22.695] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi".
[    22.695]    Entry deleted from font path.
[    22.695]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi").
[    22.695] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi".
[    22.695]    Entry deleted from font path.
[    22.695]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi").
[    22.695] (==) FontPath set to:
        /usr/share/fonts/misc,
        /usr/share/fonts/TTF
[    22.695] (==) ModulePath set to "/usr/lib/xorg/modules"
[    22.695] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    22.695] (II) Module ABI versions:
[    22.695]    X.Org ANSI C Emulation: 0.4
[    22.695]    X.Org Video Driver: 24.1
[    22.695]    X.Org XInput driver : 24.1
[    22.695]    X.Org Server Extension : 10.0
[    22.696] (++) using VT number 1

[    22.696] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    22.697] (II) xfree86: Adding drm device (/dev/dri/card0)
[    22.700] (--) PCI: (0@0:2:0) 8086:1912:1028:06e3 rev 6, Mem @ 0xdd000000/16777216, 0xb0000000/268435456, I/O @ 0x0000f000/64
[    22.700] (--) PCI:*(1@0:0:0) 10de:1382:10de:1065 rev 162, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    22.700] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    22.700] (II) LoadModule: "glx"
[    22.700] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    22.701] (II) Module glx: vendor="X.Org Foundation"
[    22.702]    compiled for 1.20.7, module version = 1.0.0
[    22.702]    ABI class: X.Org Server Extension, version 10.0
[    22.702] (==) Matched intel as autoconfigured driver 0
[    22.702] (==) Matched nouveau as autoconfigured driver 1
[    22.702] (==) Matched nv as autoconfigured driver 2
[    22.702] (==) Matched modesetting as autoconfigured driver 3
[    22.702] (==) Matched fbdev as autoconfigured driver 4
[    22.702] (==) Matched vesa as autoconfigured driver 5
[    22.702] (==) Assigned the driver to the xf86ConfigLayout
[    22.702] (II) LoadModule: "intel"
[    22.702] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    22.702] (II) Module intel: vendor="X.Org Foundation"
[    22.702]    compiled for 1.20.6, module version = 2.99.917
[    22.702]    Module class: X.Org Video Driver
[    22.702]    ABI class: X.Org Video Driver, version 24.0
[    22.702] (II) LoadModule: "nouveau"
[    22.702] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    22.702] (II) Module nouveau: vendor="X.Org Foundation"
[    22.702]    compiled for 1.20.3, module version = 1.0.16
[    22.702]    Module class: X.Org Video Driver
[    22.702]    ABI class: X.Org Video Driver, version 24.0
[    22.702] (II) LoadModule: "nv"
[    22.702] (WW) Warning, couldn't open module nv
[    22.702] (EE) Failed to load module "nv" (module does not exist, 0)
[    22.702] (II) LoadModule: "modesetting"
[    22.702] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    22.703] (II) Module modesetting: vendor="X.Org Foundation"
[    22.703]    compiled for 1.20.7, module version = 1.20.7
[    22.703]    Module class: X.Org Video Driver
[    22.703]    ABI class: X.Org Video Driver, version 24.1
[    22.703] (II) LoadModule: "fbdev"
[    22.703] (WW) Warning, couldn't open module fbdev
[    22.703] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    22.703] (II) LoadModule: "vesa"
[    22.703] (WW) Warning, couldn't open module vesa
[    22.703] (EE) Failed to load module "vesa" (module does not exist, 0)
[    22.703] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    22.703] (II) intel: Driver for Intel(R) HD Graphics
[    22.703] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[    22.703] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[    22.703] (II) NOUVEAU driver 
[    22.703] (II) NOUVEAU driver for NVIDIA chipset families :
[    22.703]    RIVA TNT            (NV04)
[    22.703]    RIVA TNT2           (NV05)
[    22.703]    GeForce 256         (NV10)
[    22.703]    GeForce 2           (NV11, NV15)
[    22.703]    GeForce 4MX         (NV17, NV18)
[    22.703]    GeForce 3           (NV20)
[    22.703]    GeForce 4Ti         (NV25, NV28)
[    22.703]    GeForce FX          (NV3x)
[    22.703]    GeForce 6           (NV4x)
[    22.703]    GeForce 7           (G7x)
[    22.703]    GeForce 8           (G8x)
[    22.703]    GeForce 9           (G9x)
[    22.703]    GeForce GTX 2xx/3xx (GT2xx)
[    22.703]    GeForce GTX 4xx/5xx (GFxxx)
[    22.703]    GeForce GTX 6xx/7xx (GKxxx)
[    22.703]    GeForce GTX 9xx     (GMxxx)
[    22.703]    GeForce GTX 10xx    (GPxxx)
[    22.703] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    22.704] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
[    22.704] (WW) Falling back to old probe method for modesetting
[    22.704] (II) modeset(1): using default device
[    22.704] (II) intel(G0): Using Kernel Mode Setting driver: i915, version 1.6.0 20190822
[    22.704] (II) intel(G0): SNA compiled from 2.99.917-899-gf66d3954
[    22.720] (EE) Screen 0 deleted because of no matching config section.
[    22.720] (II) UnloadModule: "modesetting"
[    22.720] (EE) 
Fatal server error:
[    22.720] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
[    22.721] (EE) 
[    22.721] (EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
[    22.721] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    22.721] (EE) 
[    22.721] (EE) Server terminated with error (1). Closing log file.

I used optimus switch as you can leave it permanently on whichever card you want. https://github.com/dglt1

You dont mention what DE you're on but follow the instructions in the read me (SDDM for KDE plasma; GDM for Gnome, not sure on the others.).

1 Like

Follow the guide https://github.com/dglt1/optimus-switch

1 Like

See, the thing is I want to permanently switch away from my Nvidia. I'm trying to get Linux to run only on the Intel GPU, and getting rid of the Nvidia. Optimus wouldn't work for me

I'm actually removing my Nvidia card, I don't think Optimus works for that

So you have a separate Nvidia GPU and integrated graphics?

The optimus switch disable nvidia complete and use only intel for sessions.

But in you case just only remove nvidia driver:

mhwd -l (to find which version)
mhwd -r pci video-nvidia-440xx (example)

Σημ: Άσχετο καλό το προγραμματάκι Archikos γιατί δεν το βάζεις σε release για να μην το κάνουμε compile

Yes, my integrated graphics are from my CPU, while the NVIDIA GPU will be removed from my motherboard

Προχώρα με την αφαίρεση ακόμα και τους drivers της nvidia να έχεις δεν πειράζει. Τράβα και μια διαγραφή στο φάκελο /etc/X11/xorg.conf.d/ ότι έχει σχέση με nvidia, διέγραψε το φάκελο /etc/switch/ και είσαι εντάξει.

ΠΡΟΣΟΧΗ: αν είναι ακόμα nvidia mode (λογικά ναι) επανέφερε τις αλλαγές στο /etc/lightdm/lightdm.conf, διαφορετικά θα καταλήξεις σε τερματικό.
> #display-setup-script=/usr/local/bin/optimus.sh

if this is a desktop you need only to first uninstall any MHWD video packages, disable the nvidia gpu from bios and make sure the display cable (hdmi/dp??) is plugged into the motherboard outputs and not to the gpu outputs. after you do that just install video-linux and your done.

2 Likes

Uh, hm, better install video-linux before unplugging the cable lol.

the kernel modesetting driver would still work without video-linux. also, if done before wouldn't mhwd end up creating a nouveau configuration when it detects the nvidia gpu?

Aye, I think you're right. Haven't ever had a chance to try Manjaro on a desktop PC.
As far as modesetting is concerned, I suppose kernel will handle such a trivial case anyway.

go to /etc/X11/ and delete the xorg.conf that still wants to force-load the nvidia driver although it is no longer present :wink:
Unfortunately, remaining xorg.conf files are a common problem of the non-free drivers.

1 Like

That's it, this fixed it. For me though, I had to actually remove the GPU from its port, since my BIOS doesn't have a setting.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by