How can I get my drives to be written to and read from?

Ive decided recently to plunge into the Manjaro OS and am loving it so far. Its the breath of fresh air that I needed from windows. With that being said, I am having trouble getting files onto some of my drives. I have 3 drives, on where I have the OS (ssd), one NVME m.2 drive, and a HDD. I have gone through and looked at multiple tutorials and forms and wikis to try and solve this problem however nothing has worked.

Ive made sure that the drives are mounted by using etc/fstab, Ive also used this tutorial " How to Auto Mount A Hard Drive in Manjaro The Easy Way" and that didn’t work, and I’m sure Ive done some other things but alas, didn’t work. Ive seen somewhere that I may need to change the permissions so I can write to it but it didn’t make much sense to me so I looked over it.

If you are able to help I would greatly appreciate it! Thank you in advance,

Hi. :slight_smile:

This will change the owner to your user, replace /mountpoint with the path to your mountpoint.

sudo chown -R $USER:$USER /mountpoint

You should then be able to write to it.

If that doesn’t work then post the output of these commands:

lsblk -f
cat /etc/fstab
ls /etc/systemd/system
1 Like

Its entirely possible that I messed this up, however, it did not work :frowning:

That’s ok. :slight_smile:

Please post the output of these commands:

lsblk -f
cat /etc/fstab
ls /etc/systemd/system
[apul@apul ~]$ lsblk -f
NAME   FSTYPE FSVER LABEL           UUID                                 FSAVAIL FSUSE% MOUNTPOINT
├─sda1 vfat   FAT32 NO_LABEL        A80B-060B                             299.1M     0% /boot/efi
└─sda2 ext4   1.0                   79ce5b03-3174-4cef-ba1e-18eeb9aab214   95.6G     7% /
└─sdb1 ntfs         Barracuda (4TB) C6A0D89BA0D89373                                    
└─sdc1 ntfs         500 GB M.2      08FED970FED95712                      465.7G     0% /media/Kobe
└─sdd1 vfat   FAT32 ESD-USB         087E-FC8A                                           
└─sde1 vfat   FAT32 Lexar           7AFF-BDED                                           
[apul@apul ~]$ cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=A80B-060B                            /boot/efi      vfat    umask=0077 0 2
UUID=79ce5b03-3174-4cef-ba1e-18eeb9aab214 /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

# Kobe (/dev/sdc1)
UUID=08FED970FED95712   /media/Kobe     ntfs    defaults        0       0
[apul@apul ~]$ ls /etc/systemd/system                            
dbus-org.freedesktop.nm-dispatcher.service  systemd-fsck-silent-root.service
display-manager.service                     systemd-fsck-silent@.service                

idk y the fonts are bigger and bold in some areas but thats what I got

Sorry I forgot to ask you to put the output between 3 backticks like so:



You can edit your post if you want.

I don’t use ntfs, but I’ll give it a shot. Make sure ntfs-3g is installed sudo pacman -S ntfs-3g and try the fstab entry below. Replace userid and groupid with your users uid and gid, you can get them by running id

UUID=08FED970FED95712 /media/Kobe ntfs-3g uid=userid,gid=groupid,dmask=022,fmask=133 0 0

Assuming that this doesnt work, how can I change the drive to ext4 or FAT32?

It’s pretty easy. :slight_smile:

  1. Backup any data
  2. Open gparted
  3. Select the correct drive in the top right box
  4. Make sure the partition is unmounted, if there’s a lock symbol then right click → unmount
  5. Right click on the partition and select format to → ext4 from the menu.
    5a. Select the partition, right click and select delete
    5b. Right click on the unallocated space and create a new partition using ext4
  6. Click the green tick on the toolbar (Apply All Operations)

You’ll need to change the fstab entry, you can get the UUID from lsblk -f or from gparted:

UUID=<uuid>  /media/Kobe ext4 defaults 0 0

Then run:

sudo mount -a
sudo chown -R $USER:$USER /media/Kobe

Ive done everything you’ve told me, thank you for you patience, however, now I’m getting an access denied message.

Which one? Are we trying to get the ntfs working or are we re-formatting?

Where did it come from?
Why haven’t you pasted it here?

lsblk -f
cat /etc/fstab


I reformatted the drives figuring it easier to deal with and to your credit it was.

I came from the end of the process after the mounting and after the
sudo chown -R $USER:$USER /media/Kobe command.
I cannot paste it because the “Information-Dolphin” Windows wont allow it, however it reads, "Access Denied. Could not write to /media/Kobe/[some random file Ive been trying to drag into there]

I apologize for how annoying this problem is for you and I greatly appreciate your time

Sorry was out all day, going to be out tomorrow too.

It’s not, and you’re welcome, but it’s not fixed it yet. More information would be good though. :slight_smile:

Can you run these and post the output between 3 backticks, like I showed above, please.

lsblk -f
cat /etc/fstab
ls -l /media
touch /media/Kobe/testfile
sudo touch /media/Kobe/testfile