How can I fix a "can't read superblock" error on an encrypted disk?

Here is the current error message I get when I try to boot into my encrypted disk :

mount: /openswap_keymount: can’t read superblock on /dev/mapper/luks-d5…
Failed to open key file.
umount: can’t unmount openswap_keymount: invalid argument
mount: /new_root: can’t read superblock on /dev/mapper/luks…
You are now being dropped into an emergency shell.
sh: can’t access tty: job control turned off

I’ve tried this solution : 111// (I can’t post links, replace “111” by https:)
sudo fsck /dev/sda1 didn’t work. There was a problem on this partition, but since the error message doesn’t mention sda1, I guess that’s not the proper way to fix this.
I tried to find the encrypted partition with lsblk but it doesn’t appear.

Is it the proper way to fix this ? Can anyone guide me a little bit through this ?
Thank you very much !

you have to do commands lukopens before apply a fsck

see this

Hello stephane, thank you very much for your time and your help ! It works now.
Have a very nice day !

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.