How can i do root action with Dolphin?

After half year of using Manjaro as my first distribution and being satisfied from it, i reinstalled it and i noticed that with the Dolphin right click menu there is no "root action" as there was before.

I want to move a folder of fonts that i downloaded to usr/share/fonts folder but i don't know how to do it with Dolphin.
I guess i can do it with sudo from command line, but i remember there was "root actions" before on the Dolphin menu.
The all idea of distribution like Manjaro is doing whatever possible with GUI and not using command line.

You need to install the package kde-servicemenus-rootactions

5 Likes

Settings -> Configure Dolphin -> Services.

There, make sure that all the Root Actions you want to use are checked. If they are not available, you can install them from that menu.

EDIT: or do as @dalto suggested, but make sure they are checked.

4 Likes

there is no 'Settings -> Configure Dolphin -> Services'.
I checked carefully and couldn't find that option in Settings.
I'll try the other option.

image

3 Likes

I found it.
Its in the Hamburger menu.
I installed several services and i get an error:
'Could not find the program 'rootactions-servicemenu.pl'

Half year ago i was curios about Linux and installed Manjaro and everything worked fine right at the beginning including gaming and that is why i moved to Linux.
I just i dont understand why they had to change things and complicate it.
I dont have the same experience as before.

Do this:

to get this:

3 Likes

Personally, I really like having a separate file manager for stuff like this so that way I don't accidentally do something stupid. I prefer pcmanfm and run it via sudo from terminal when I need to do something like that. Otherwise, everyone has already pointed the package if you just want to use it in dolphin.

2 Likes

Yes..better use the command line.
I'm wasting my time.

I have all services checked just as it is in the picture you attached and still i get error:
"Could not find the program 'rootactions-servicemenu.pl"

I don't believe dolphin will let do root things EVEN if you start it from sudo in terminal (currently on Cinnamon). You would need that plugin, or another filemanager.

If you'd like a terminal file manager and are comfortable doing that, ranger is also a great option. I prefer GUI though.

All i want is to move fonts folder to usr/share/fonts.
That is how i understood i can install new fonts.

I would install them straight from AUR if possible, they have LOADS. That's the easiest way IMO. I have no experience installing them any other way. But if all you have to do is move them from one to the other, this is how I would go about that.

I see you're new - I don't know if you're new to Linux/Manjaro, or just to the forum. If you're looking for fonts I would check out https://aur.archlinux.org/packages/?O=0&K=ttf

Many font packages have ttf in them, but you can always search the entirety of it to find what you're looking for. You can also search them via your update manager if you go into preferences and allow AUR access. You will be able to search and install right from there.

If you're just looking to move a file in a GUI with root priviliages, I still recommend pcmanfm personally. Dual pane mode, and show hidden files, and it's as simple as drag and drop.

2 Likes

That's wrong. And you should never run Dolphin with sudo.

1 Like

I thought I tried it with Dolphin. Maybe it was Thunar then. There was one mainline DE filemanager that wouldn't let me do it.

and just because you SHOULDN'T doesn't mean you can't do something. But I definitely agree, you should not in general run any file manager with sudo unless you know exactly what you're doing.

I used to have to run my filemanager as root to install new backgrounds for my desktop. That's just how it works with i3/nitrogen. So, never is a bit extreme. In general though I definitely agree with you.

1 Like

With KDE, you can install fonts from a file by using System Settings > Appearance > Fonts > Font Management and click on "Install from file."

You can also search for and install new files from there.

3 Likes

Ok...you solution worked.
I didn't know the AUR contains fonts libraries.
Besides only some of those libraries managed to install the rest failed.
But it worked :slight_smile:

Glad to help. I always start with Manjaro repos, then AUR, then other options when looking for anything.

And again, welcome to the forum!

:slightly_smiling_face:

You cant run dolphin with sudo. It will stop you.
The thing is you shouldnt be running any GUI application as root.
(I think one of the few exceptions is nvidia util .. because nvidia)
When you sudo GUI-APP you not only can possibly damage permissions and all that ... but you hand sudo keys over to all of X (that thing that draws stuff on your screen) .. which has never been and never will be made secure against such usage. Thousands and thousands of lines of code were just fed with sudo and given those privileges. That can create structural issues .. but namely its a huge security hole.

2 Likes

Forum kindly sponsored by