Hover messes up Icons

Icons are messed up throughout all panels after the new update. For example on the default bar icons appear correctly at first. But if I hover over, the icon disappears and moves to the top left of the panel.

Things I have tried:

  1. Deleting cache files
  2. Resetting themes and icons
  3. kbuildsycoca6 --noincremental
  4. Reinstalling nvidia drivers
  5. Reinstalling KDE (including kde, plasma, plasma-desktop, kio-extras, kde-applications, qt6ct)
  6. Rebooting sddm service
  7. killall plasmashell && kstart plasmashell

It is possible that either your icon theme or your Plasma style (or both) are no longer compatible with Plasma 6. Try switching them to a more recent theme.

It happens with whatever theme I try, for example the Breath Dark and Breeze Dark, default themes

Can you create a new user and test with it?

This seems to work, the new user doesn’t have the same issue.
Is there an easy way to reset my user/formatting without removing important files or software?

All users share the same installed apps, only configs will be different, what you need is copy your personnel file to another partition then login to that new user and copy them from there.

Plasma full reset is a huge task to do, because many kcm modules, plasma components, widgets and apps do things differently, so add your voice here.

1 Like

Thanks for the help, it is definitely annoying that migrating my home directory to a new user is the “easiest” fix

That is not the fix.
The fix is
As is suggested after big plasma updates, and is mentioned in every thread relating to the recent plasma6 upgrade.
But you will need to set your configurations again.

A button would be nice … I guess … But adding to a bug report requesting one is not a solution.
Performing the refresh actions could be.

I will type it out again.
This time will be a single string with some added messaging.

cd ~/.config && for j in plasma*; do mv -- "$j" "${j%}.bak"; done && mv Trolltech.conf Trolltech.conf.bak && rm -rf ~/.cache/* && kbuildsycoca6 --noincremental && cd ~ && echo -e "\nFinished Clearing Plasma Settings and User Cache.\n\nPlease Reboot.\n"
1 Like

KDE devs are not like other Linux communities where the direction of the project is decided by a limited number of persons (e.g GNOME…), they are open and let everyone fill bugs and request features on their bug tracker and GitLab, you can even criticize their work on their forum, and you will never get banned.

This makes most KDE decisions driven by users interaction via their tracker or forum, so a bug or request starts with normal priority then when many users add their comments and explain the need or necessity for it, the priority jumps to High or Very High.

This way of elevating priority worked many times to attract KDE devs, because most of them contribute to KDE projects in their free time, and with the huge number of requested features it can be hard to decide, so users can help them, you can even directly sponsor a feature if you have money.

That Arch wiki has some old solutions that are not possible to apply because the UI and even configs changed before even Plasma 6.

How does the clearing of items in .config and .cache not apply?

It does.

I’m not talking about removing .config files or .cache, but about some other propositions made in that wiki page.

But thats what the link points to.

Its exactly where it goes and it does exactly what would fix the situation.

Correct ones are:



Those are the 2 sections in the link above.
Are you telling me it is somehow not understood that those are what is meant?
I struggle to understand that … especially after I even typed it out.

Just to make sure that average user doesn’t apply what is written in all those sub sections. :wink:

These commands did not fix my issue, I already stated in my original post that I deleted the cache/config files and the issue persisted

Your post doesnt mention .config anywhere.
And if a new user works … its something in your HOME.

Sure i still dont know what hidden file is the cause, the issue persisted in the new user after transferring all files. It isn’t the config and cache (steps 1 and 3 that I listed above forgetting to mention I also rm all config files not just Trolltech.conf, following the KDE - ArchWiki guide).

rm -rf ~/.cache/*
rm ~/.config/*
kbuildsycoca6 --noincremental

After wiping all hidden files and folders (beyond just cache and config files) in the home directory, it finally resolved my problem

rm -rf ~/.*

There are also some in ~/.local/share that you might go looking for.
Anything with kde*, k*, plasma* could be.

This is extremely drastic and not really advisable.