Hotspot Wifi slow

Hello everyone,

I’m running a dual-boot manjaro(gnome) and Win10 machine. The machine is connected to the internet with a 100 Mbit/s copper-cable. Due to the fact, that I’ve no wifi in my room, I’m running a Wi-Fi- Hotspot on this machine. This hotspot is running on the 5Ghz-Network. When I run a speedtest with a device connected to my manjaro hotspot I get approximate 5 Mbit/s. When I then reboot my machine and start to “Windows 10” I get about 50 Mbit/s (2.4 Ghz). (The ping stays approximate the same with less then four ms.)
I want to speed up my manjaro hotspot-Wifi speed, since I rarely use Windows 10. (Less then 10% of my time, and only if I need it for work.)

What I’ve already tried are the following points(from Slow speed on Hotspot created from Ubuntu 16.04 with RTL8723BE Wireless Network Adapter - Ask Ubuntu)

  1. Play with the antennae number
  2. Play with the power saving modes
  3. I checked even the entropy level, which is over 3000
  4. I tried also changing to the 2.4 Ghz Band, but then the speed dropped to 0.5 Mbit/s

(Funny was, yesterday when the hotspot window problem was, I was playing around with these possible solutions and then I thought I broke something.

So I’m asking you, what you consider to be other options to speed up my wifi-hotspot? (If you need additional information, just say so, due to the fact, that I’m not sure, what may is still relevant.)

Thanks for your answers in advance.
PS: Even if I read my writing twice, I’m excusing myself for any mistakes.

Edit: As @TriMoon suggested I provide some further information about my system: (I’m sorry for not providing it immediately)

 Kernel: 5.9.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
 parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
 root=UUID=8b47f208-1cb5-4900-8061-5aa234642224 rw apparmor=1 
 security=apparmor udev.log_priority=3 
 Desktop: GNOME 3.38.2 tk: GTK 3.24.24 wm: gnome-shell dm: GDM 3.38.2 
 Distro: Manjaro Linux 
 Type: Desktop Mobo: Acer model: Predator G3-605 serial: <filter> 
 UEFI: American Megatrends v: P11-C1 date: 09/12/2014 
 Info: Quad Core model: Intel Core i7-4790 bits: 64 type: MT MCP 
 arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 28 
 L2 cache: 8192 KiB 
 flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
 bogomips: 57480 
 Speed: 3591 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 3592 2: 2820 
 3: 3592 4: 3592 5: 3591 6: 3594 7: 3594 8: 3594 
 Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
 Type: l1tf 
 mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
 Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
 Type: meltdown mitigation: PTI 
 Type: spec_store_bypass 
 mitigation: Speculative Store Bypass disabled via prctl and seccomp 
 Type: spectre_v1 
 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
 Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
 IBRS_FW, STIBP: conditional, RSB filling 
 Type: srbds mitigation: Microcode 
 Type: tsx_async_abort status: Not affected 
 Device-1: NVIDIA GM107 [GeForce GTX 745] 
 vendor: PC Partner Limited / Sapphire driver: nvidia v: 455.45.01 
 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1382 
 Display: x11 server: 1.20.10 compositor: gnome-shell driver: nvidia 
 resolution: <missing: xdpyinfo> 
 OpenGL: renderer: GeForce GTX 745/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 
 direct render: Yes 
 Device-1: Intel 8 Series/C220 Series High Definition Audio 
 vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
 bus ID: 00:1b.0 chip ID: 8086:8c20 
 Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX] 
 vendor: PC Partner Limited / Sapphire driver: snd_hda_intel v: kernel 
 bus ID: 01:00.1 chip ID: 10de:0fbc 
 Device-3: Kingston HyperX Cloud Stinger Core Wireless + 7.1 type: USB 
 driver: hid-generic,snd-usb-audio,usbhid bus ID: 2-1:2 chip ID: 0951:170b 
 serial: <filter> 
 Sound Server: ALSA v: k5.9.12-1-MANJARO 
 Device-1: Intel Ethernet I217-V vendor: Acer Incorporated ALI driver: e1000e 
 v: kernel port: f040 bus ID: 00:19.0 chip ID: 8086:153b 
 IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
 Device-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter 
 vendor: AzureWave driver: rtl8821ae v: kernel port: d000 bus ID: 03:00.0 
 chip ID: 10ec:8821 
 IF: wlp3s0 state: up mac: <filter> 
 Local Storage: total: 2.04 TiB used: 417.03 GiB (20.0%) 
 SMART Message: Unable to run smartctl. Root privileges required. 
 ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-21M2NA0 
 size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
 rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: GPT 
 ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-00BN5A0 
 size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
 rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: GPT 
 ID-3: /dev/sdc vendor: Western Digital model: WDS240G2G0A-00JH30 
 size: 223.58 GiB block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
 serial: <filter> rev: 0000 scheme: GPT 
 ID-1: / raw size: 64.26 GiB size: 62.75 GiB (97.65%) used: 44.20 GiB (70.4%) 
 fs: ext4 dev: /dev/sdc9 
 Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
 ID-1: swap-1 type: partition size: 12.21 GiB used: 0 KiB (0.0%) priority: -2 
 dev: /dev/sdc7 
 System Temperatures: cpu: 46.0 C mobo: 27.8 C gpu: nvidia temp: 57 C 
 Fan Speeds (RPM): cpu: 841 fan-1: 0 fan-3: 0 fan-4: 0 fan-5: 0 gpu: nvidia 
 fan: 35% 
 Power: 12v: N/A 5v: N/A 3.3v: 3.33 vbat: 3.30 
 Processes: 289 Uptime: 3h 17m wakeups: 0 Memory: 15.56 GiB 
 used: 4.96 GiB (31.9%) Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 
 pacman: 1682 lib: 381 flatpak: 0 Shell: Zsh v: 5.8 
 running in: gnome-terminal inxi: 3.1.09 

I’ve made my hotspot as suggested here: with option 2. And I’m using “WPA & WPA2 Personal” as security method.

It might help if you provided detailed info on how you setup your Wifi Hotspot in Manjaro with related configs.

Also, did you use the driver mentioned in that topic from the link in:

Anyhow, help others to help you better by providing enough info about your computer and it’s hardware.
Because with things like this it could be related to drivers and/or kernel etc. beside software configurations.

Thanks for your answer. I’ve not seen this driver. I will take a look at it, this evening and update you as soon as possible. (I’m currently working and can’t try out new drivers…)

So I’ve taken a look at the driver and during reading the “” file I’ve found:

Note: If your kernel is 4.17 or newer, AND your card is not an RTL8723DE, then you should NOT be
using the external driver. The built-in one is the same.

This applies to me, since I’m running a 5.9.12 and RTL8821AE is not RTL8723DE, so unfortunately it does not apply to my case. So therefore no need to install the new driver.