/home is not being mounted on boot

Tonight I’ve left my PC in sleep mode and when I came back to it in the morning and tried to save a project I got an error that the filesystem is in read only mode. I rebooted and I was put in emergency mode.
The error message I was prompted there:

[FAILED] Failed to start File System¤d-5a86-4a35-affe-138269d28d43.
[DEFEND] Dependency failed for /home.
[DEFEND] Dependency failed for Local File Systems.

I ran lsblk and my /home wasn’t mounted, so I mounted it, checked the fstab (which was correct), exited and my system booted. I rebooted again to test it and I got the same errors. My fstab is still correct but for some reason I have to manually mount my /home in emergency mode. Any ideas?

What is the content of the fstab ? Cuz this error looks pretty straight forward
(besides that it has an odd appearance/formatting/location)

In addition add output of

sudo blkid
1 Like

This is the output of lsblk -f (note that my /home is mounted as I am currently using the machine and mounted it manually in the recovery mode):

│ ntfs Storage
│ 32F3158008731B11
│ ntfs Programs
│ 4E6AE40131FFB5C7
│ ntfs Backup
│ 7CF1A285677322CE
│ ntfs Torrent
│ 57C9D97B103CEE13 223,9G 50% /run/media
│ ntfs Windows
│ 3CF6B08025C146D9
│ ntfs CA08805B08804901
│ vfat FAT32 F0AA-68B5

BitLoc 2
│ vfat FAT32 03D8-0C2F 510,7M 0% /boot/efi
│ swap 1 9ab8b6d5-bd6f-41ab-abb7-56df934b8b42 [SWAP]
│ ext4 1.0 1b6a5a40-b199-402c-a80c-a3c6b79b0a0c 44,2G 20% /
ext4 1.0 a495cdfd-5a86-4a35-affe-138269d28d43 106,6G 4% /home
sdc iso966 Jolie MANJARO_GNOMEM_2012
│ 2020-10-19-12-48-16-00
│ iso966 Jolie MANJARO_GNOMEM_2012
│ 2020-10-19-12-48-16-00 0 100% /run/media

This is the content of the fstab:

# <file system> <mount point> <type> <options> <dump> <pass>
UUID=03D8-0C2F /boot/efi vfat umask=0077 0 2
UUID=9ab8b6d5-bd6f-41ab-abb7-56df934b8b42 swap swap defaults,noatime 0 2
UUID=1b6a5a40-b199-402c-a80c-a3c6b79b0a0c / ext4 defaults,noatime 0 1
UUID=a495cdfd-5a86-4a35-affe-138269d28d43 /home ext4 defaults,noatime 0 2
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0

The file system on my /dev/sdb4 (mount point of /home) was corrupted. Running fsck.ext4 /dev/sdb4 solved the problem.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.