/home directory is not mounted on boot

Hi,
the title says it all. My /home dir is not mounted on boot. I looked at this post: https://forum.manjaro.org/t/solved-problem-mounting-home-system-won-t-boot/96677/3 and could not find the answer.
The contents of the fstab are:

UUID=5BE0-A17E                            /boot/efi      vfat    umask=0077 0 2
UUID=07087751-cb16-4a0f-8611-692e6e9d6d09 swap           swap    defaults,noatime,discard 0 2
UUID=354f3ea7-f41d-4751-bc4b-8d6df155780b /              ext4    defaults,noatime,discard 0 1
UUID=15ac2194-f7db-4d0a-b3ff-0903de824f2f /home          ext4    defaults,noatime 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

and from the lsblk -o NAME,TYPE,FSTYPE,UUID,SIZE:

sda    disk                                               232,9G
├─sda1 part vfat     5BE0-A17E                              500M
├─sda2 part ext4     354f3ea7-f41d-4751-bc4b-8d6df155780b 224,6G
└─sda3 part swap     07087751-cb16-4a0f-8611-692e6e9d6d09   7,8G
sdb    disk                                                 3,7T
└─sdb1 part ext4     15ac2194-f7db-4d0a-b3ff-0903de824f2f   3,7T
sr0    rom                                                 1024M

I do not a have clue where to start to solve this.
Any help appreciated
Thanks in advance

It looks like your disk /dev/sdb is formatted in msdos, for msdos parted disk there is a size limit (2 TB). Make backups and convert the format to gpt as shown in the link.

https://wiki.archlinux.org/index.php/GPT_fdisk#Convert_between_MBR_and_GPT

Or reduce the size of the partition /dev/sdb1 below 2 TB.

1 Like

In addition to what @Wollie said, remove the discard mount option from your SSD partitions and use fstrim.timer instead. Enabling that is a one-time operation. :arrow_down:

sudo systemctl enable fstrim.timer --now
2 Likes

I don't think that's correct:

I can't see anything wrong in that fstab.

Without it mounted, does /home exist (doesn't need to), and what permissions does it have?

Can you mount the drive manually, as root?

mount /dev/sdb1 /home

To give us some more clarity of your disk format schemes, please provide output of

sudo parted -l
1 Like

Here is the output from sudo parted -l

Model: ATA Samsung SSD 850 (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  525MB   524MB   fat32                 msftdata
 3      525MB   8914MB  8389MB  linux-swap(v1)        swap
 2      8914MB  250GB   241GB   ext4


Model: ATA WDC WD40EZRZ-00G (scsi)
Disk /dev/sdb: 4001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 1      1049kB  4001GB  4001GB  ext4

Currently I am mounting /home manually on each startup

mount /home

is this correct?

i would think so

UUID=07087751-cb16-4a0f-8611-692e6e9d6d09 none		 swap	 defaults,noatime,discard 0 0

(swap => none) (0 2 => 0 0)?

also worth trying: put "swap" down before "tmpfs"

but doesn't really solve your problem now .. sorry

Your partition /dev/sda1 should have a boot flag.

With regard to your inaccessible /home partition I would boot into a live ISO and check if your anticipated /home partition is still called /dev/sdb1 (e.g. by command sudo parted -l) and then run

sudo fsck /dev/sdb1

You could also check if ownership and attributes of /home are set correct if you have it mounted manually. It should be

drwxr-xr-x root root

Not sure if this is relevant but out of curiousity, what does
systemctl status home.mount
say?

Forum kindly sponsored by