Hindi language support not working


#1

Please add language support hi_IN.UTF-8 in manjaro system for hindi support








#2

i also think manjaro needs to add this as many apps like lutris jgmenu dont work when locale is en in


#3

My Manjaro

$ cat /etc/locale.gen | grep -i hi
#  A list of supported locales is included in this file.
#hi_IN UTF-8  
#hif_FJ UTF-8 

Check yours.
If they exist, enable by un-commenting and running

sudo locale-gen

so you have them available.

Edit: Or use Manjaro Settings Manager


#4

manjaro dont have hi_IN.UTF-8
and also we dont have en_IN.UTF-8
it makes big difference having (.)and not having it.


#5

My i3 has it, or?

~ >>> cat /etc/locale.gen | grep -i hi                                                                                           [1]
#  A list of supported locales is included in this file.
#hi_IN UTF-8  
#hif_FJ UTF-8  
~ >>> cat /etc/locale.gen | grep -i en_IN                                                                                           
#en_IN UTF-8  

The locale-gen command will generate all the locales,
placing them in /usr/lib/locale.


#6

Can you explain what you mean?
I don’t understand.


#7

see i dont know if it makes a difference
but we have
en_US.UTF-8
and
en_IN UTF-8

see there the dot is missing in en_IN UTF-8
when locale is set as such some applications return as incorrect locale.
you can try running jgmenu with en_in UTF-8
as locale.


#8

So the problem is not in every aspect of “Manjaro”, only some programs. Correct?
I asked for explanation, but I get some words. Can you use more time and more words to explain the issue?
Also, is this what OP has?
I showed some command output. Can you show me yours?
No message, no error, no issue…


#9

because i know the error so i always use en_US.UTF-8
as locale.
i knew this error when i tried to install openbox edition in live it worked okay.but after install menu did not work.so after some tests i concluded its problem with locale as the live iso locale is en_us and mine was en_in.so i did reinstall with locale as en_us and it has become my habit to always use en_us now.as i encountered lutris not launching.steam not working properly.multibootusb also did not work.


#10

If this is the case, this should be reported as a bug upstream.
/etc/locale.gen is owned by glibc, so it should be reported to that project.

Manjaro can’t support more languages than glibc does.


#11

Thank you for the history, but we need the present facts.
Ⓦⓗⓔⓡⓔ is the problem.


#12

i dont have the jgmenu and en in locale now but


#13

So you have created a topic and trying to get attention… :sweat_smile:

Can you help on this topic?

Helping others may help you as well…
I do that every day :wink:


#14

as strit mentioned we need to report this to upstream.to solve this long standing problem.
and it might be there for every locale which dont have postfix as .UTF-8.


#15

Yeah. You found the bug, know what it’s about, so you should report it. :slight_smile:


#16

so where should i report i cant seem to find the repository for it.


#17

One quick google search:
https://www.gnu.org/software/libc/bugs.html


#19

but one thing i cant understand is if its glibc related then why linux mint has hi_IN.UTF-8
and manjaro doesn’t.


#20

Maybe they patched it?


#21

What does @umesh think about everything :smiley: