High res screen with new install gets tiny fonts and icons

My first manjoro install (first linux in years).
I have an alienware m17 r3 laptop with 3840x2160 screen.
Kernel is 5.8.16-2-MANJARO.
lspci says: Intel Corporation UHD Graphics (rev 05), and NVIDIA Corporation TU106M [GeForce RTX 2060 Mobile] (rev a1).
xfce 4.14

After the install, everything on the screen is too tiny: fonts, icons and menu text.
I found “xfce4-setttings-manager settings -> appearance -> settings -> window scaling” but I’m not sure if that’s the right approach.
What should I do?

[please let me know if I missed posting any appropriate system data – my first posting here]

XFCE isnt perfect with high dpi. (best are probably Gnome and KDE)
But you should be able to set a custom DPI such as in your case, probably
192 (2x), 216 (2.25x), 240 (2.5x)

Hmm, my physical screen is 15 inches wide, so 3840/15 = 256.
OK, so how do I make that change?

I think the DPI setting in XFCE is under fonts.
[note: generally moves in increments of .25x are best. (264 is 2.75x)]

OK, I found and changed font DPI and icon size using xfce4-settings-manager, and rebooted, but the changes didn’t appear to take effect. Is there something I have to do after using the settings-manager to make my changes stick? I can’t find a man page for this app.

Hum.
That doesnt seem right to me.
But then again … I havent dealt with xfce hidpi in a while.

Please see this:
https://wiki.archlinux.org/index.php/HiDPI#Xfce

(which…oh yeah … reminds me … you probably need special ‘hidpi’ themes in xfce)

Hmm, read the HiPPI#Xfce doc, fixed hidpi theme and scaling, and rebooted. Still no effect on everything on screen being nearly unusably tiny. Any suggestion on how to proceed? Do I need to ditch xfce and use some other desktop manager? (and how do I do that?)

– George

I honestly feel that with hidpi you should use Gnome or KDE.
I am pretty sure folks use hidpi with xfce … but my understanding is its not quite easily compatible.
If you decide to go that route … its probably best to backup your data and reinstall from the respective ISO. At least thats my preference as opposed to a messy addition.

KDE it is then. Thanks very much for your help!

Alrighty. Cheers.
Hey… by the way… try using the normal system settings and such to tune your hidpi in plasma.
But
If you find it doesnt work perfectly (like I did)… then you might consider this script:

OK, got manjaro kde. Docs refer to “system settings”, but I don’t see how to get to this menu. RIght click on background only gets “configure desktop” which doesn’t seem to help. How dol I get to the “normal system settings”?

Just launch System Settings (or any submodule) from the application menu.