High Performance PC aber stottern und ruckeln

Hallo
Ich habe die neuste Version von Manjaro und Kernel 4.20.11-1
Mein PC hat einen i7 8700k und eine RTX 2070.
In RUST z.B. werden mir 90fps angezeigt was ja ganz gut geht aber trotzdem ruckelt es wie verrückt. Auch in Minecraft merkt man das. Dort hab ich 250+ fps aber es stottert trotzdem. Dasselbe merkt man auch auf dem Desktop. Das Fenster verschieben ruckelt genau so.
Vorher hatte ich einen Laptop mit einer GTX980M drin. Dort hatte ich die Probleme nicht. Ich habe den Nvidia Treiber 415.27 drauf.
Ich würde so gerne komplett zu Linux wechsel. Aber mit diesen Problemen ist es leider nicht möglich. Hat vielleicht jemand eine Lösung? Ist die Hardware zu neu?

Gruß
Patrick

Es gibt auf der Nvidia Seite schon einen Graiktreiber 418.43.

Das Problem mit dem Ruckeln unter Linux mit der RTX 20xx ist auch bekannt.

Danke für die Antwort Keruskerfuerst

Um einen Treiber von Hand zu installieren bin ich leider noch zu neu in Linux. Ist mit der 418er Version das Problem behoben oder wird noch daran gearbeitet?

Der 418er Treiber ist bereits in testing, denke aber nicht dass es einen grossen Unterschied ausmacht.
Ich weiss nicht, welches DE du benutzt, aber bei KDE kann es helfen, den Compositor zu deaktivieren (Alt-Shift-F12).
Ebenfalls kann man den “Performance” governor auswählen mit:
sudo cpupower frequency-set -g performance

can you post:

inxi -FGxxxz
nvidia-smi
grep -v ^# /etc/X11/xorg.conf.d/*.conf
grep -v ^# /etc/X11/mhwd.d/*.conf

post terminal uitvoer in het juiste formaat met 3 backtics `` `boven en onder terminaluitgang, u kunt ook de **** knop boven het tekstinvoervak ​​gebruiken en vervolgens plakken.

</> button

sorry, ik spreek geen Nederlands en ik gebruik een vertaler

System:
  Host: patrick-pc Kernel: 4.20.11-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN tk: Gtk 3.24.3 info: xfce4-panel 
  wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: Micro-Star model: MPG Z390 GAMING EDGE AC (MS-7B17) 
  v: 2.0 serial: <filter> UEFI: American Megatrends v: A.30 date: 01/22/2019 
CPU:
  Topology: 6-Core model: Intel Core i7-8700K bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 88728 
  Speed: 800 MHz min/max: 800/4700 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 801 7: 801 8: 800 9: 800 10: 800 11: 800 12: 800 
Graphics:
  Device-1: NVIDIA TU106 [GeForce RTX 2070] vendor: Gigabyte driver: nvidia 
  v: 415.27 bus ID: 01:00.0 chip ID: 10de:1f07 
  Display: x11 server: X.Org 1.20.3 driver: nvidia tty: N/A 
  OpenGL: renderer: GeForce RTX 2070/PCIe/SSE2 v: 4.6.0 NVIDIA 415.27 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Device-2: NVIDIA TU106 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f9 
  Device-3: Logitech G430 Surround Sound Gaming Headset type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-13.2:7 
  chip ID: 046d:0a4d 
  Sound Server: ALSA v: k4.20.11-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
  v: kernel bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlo1 state: down mac: <filter> 
  Device-2: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e 
  v: 3.2.6-k port: efa0 bus ID: 00:1f.6 chip ID: 8086:15bc 
  IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.36 TiB used: 25.43 GiB (1.8%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB 
  size: 465.76 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 2B2QEXE7 
  scheme: GPT 
  ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 
  size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> 
  rev: A3J0 scheme: GPT 
Partition:
  ID-1: / size: 57.44 GiB used: 25.40 GiB (44.2%) fs: ext4 
  dev: /dev/nvme0n1p5 
Sensors:
  System Temperatures: cpu: 56.0 C mobo: N/A gpu: nvidia temp: 55 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 274 Uptime: 2m Memory: 15.60 GiB used: 1017.5 MiB (6.4%) 
  Init: systemd v: 241 Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 
  running in: xfce4-terminal inxi: 3.0.30 
Sat Mar  2 21:54:35 2019       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 415.27       Driver Version: 415.27       CUDA Version: 10.0     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce RTX 2070    Off  | 00000000:01:00.0  On |                  N/A |
|  0%   52C    P8    14W / 215W |    114MiB /  7949MiB |      6%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0       812      G   /usr/lib/Xorg                                112MiB |
+-----------------------------------------------------------------------------+
/etc/X11/xorg.conf.d/00-keyboard.conf:Section "InputClass"
/etc/X11/xorg.conf.d/00-keyboard.conf:        Identifier "system-keyboard"
/etc/X11/xorg.conf.d/00-keyboard.conf:        MatchIsKeyboard "on"
/etc/X11/xorg.conf.d/00-keyboard.conf:        Option "XkbLayout" "de"
/etc/X11/xorg.conf.d/00-keyboard.conf:        Option "XkbModel" "pc105"
/etc/X11/xorg.conf.d/00-keyboard.conf:EndSection
/etc/X11/xorg.conf.d/90-mhwd.conf:
/etc/X11/xorg.conf.d/90-mhwd.conf:Section "ServerLayout"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Identifier     "Layout0"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Screen      0  "Screen0"
/etc/X11/xorg.conf.d/90-mhwd.conf:    InputDevice    "Keyboard0" "CoreKeyboard"
/etc/X11/xorg.conf.d/90-mhwd.conf:    InputDevice    "Mouse0" "CorePointer"
/etc/X11/xorg.conf.d/90-mhwd.conf:EndSection
/etc/X11/xorg.conf.d/90-mhwd.conf:
/etc/X11/xorg.conf.d/90-mhwd.conf:Section "Files"
/etc/X11/xorg.conf.d/90-mhwd.conf:EndSection
/etc/X11/xorg.conf.d/90-mhwd.conf:
/etc/X11/xorg.conf.d/90-mhwd.conf:Section "InputDevice"
/etc/X11/xorg.conf.d/90-mhwd.conf:    # generated from default
/etc/X11/xorg.conf.d/90-mhwd.conf:    Identifier     "Mouse0"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Driver         "mouse"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Option         "Protocol" "auto"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Option         "Device" "/dev/psaux"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Option         "Emulate3Buttons" "no"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Option         "ZAxisMapping" "4 5"
/etc/X11/xorg.conf.d/90-mhwd.conf:EndSection
/etc/X11/xorg.conf.d/90-mhwd.conf:
/etc/X11/xorg.conf.d/90-mhwd.conf:Section "InputDevice"
/etc/X11/xorg.conf.d/90-mhwd.conf:    # generated from default
/etc/X11/xorg.conf.d/90-mhwd.conf:    Identifier     "Keyboard0"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Driver         "kbd"
/etc/X11/xorg.conf.d/90-mhwd.conf:EndSection
/etc/X11/xorg.conf.d/90-mhwd.conf:
/etc/X11/xorg.conf.d/90-mhwd.conf:Section "Monitor"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Identifier     "Monitor0"
/etc/X11/xorg.conf.d/90-mhwd.conf:    VendorName     "Unknown"
/etc/X11/xorg.conf.d/90-mhwd.conf:    ModelName      "Unknown"
/etc/X11/xorg.conf.d/90-mhwd.conf:    HorizSync       28.0 - 33.0
/etc/X11/xorg.conf.d/90-mhwd.conf:    VertRefresh     43.0 - 72.0
/etc/X11/xorg.conf.d/90-mhwd.conf:    Option         "DPMS"
/etc/X11/xorg.conf.d/90-mhwd.conf:EndSection
/etc/X11/xorg.conf.d/90-mhwd.conf:
/etc/X11/xorg.conf.d/90-mhwd.conf:Section "Device"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Identifier     "Device0"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Driver         "nvidia"
/etc/X11/xorg.conf.d/90-mhwd.conf:    VendorName     "NVIDIA Corporation"
/etc/X11/xorg.conf.d/90-mhwd.conf:	Option "NoLogo" "1"
/etc/X11/xorg.conf.d/90-mhwd.conf:EndSection
/etc/X11/xorg.conf.d/90-mhwd.conf:
/etc/X11/xorg.conf.d/90-mhwd.conf:Section "Screen"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Identifier     "Screen0"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Device         "Device0"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Monitor        "Monitor0"
/etc/X11/xorg.conf.d/90-mhwd.conf:    DefaultDepth    24
/etc/X11/xorg.conf.d/90-mhwd.conf:    SubSection     "Display"
/etc/X11/xorg.conf.d/90-mhwd.conf:        Depth       24
/etc/X11/xorg.conf.d/90-mhwd.conf:    EndSubSection
/etc/X11/xorg.conf.d/90-mhwd.conf:EndSection
/etc/X11/xorg.conf.d/90-mhwd.conf:
/etc/X11/xorg.conf.d/90-mhwd.conf:Section "Extensions"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Option         "COMPOSITE" "Enable"
/etc/X11/xorg.conf.d/90-mhwd.conf:EndSection
/etc/X11/xorg.conf.d/90-mhwd.conf:
/etc/X11/xorg.conf.d/90-mhwd.conf: 
/etc/X11/xorg.conf.d/90-mhwd.conf:Section "InputClass"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Identifier          "Keyboard Defaults"
/etc/X11/xorg.conf.d/90-mhwd.conf:    MatchIsKeyboard        "yes"
/etc/X11/xorg.conf.d/90-mhwd.conf:    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
/etc/X11/xorg.conf.d/90-mhwd.conf:EndSection
/etc/X11/xorg.conf.d/90-mhwd.conf: 
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "COMPOSITE" "Enable"
EndSection

 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
1 Like

And i dont speak nederlands either. i speak german and english :slight_smile:

im just a culturally handicapped american so i couldnt tell the difference anyway :grin:

i was trying to say to put 3 backtics ``` above and below the terminal output so its formatted properly, you can also use the </> button above the post entry box to do the same thing.

it makes reading outputs much easier, if you could edit and add those it would great

Done :slight_smile:
Should be better now. Thanks :slight_smile:

1 Like

ok, can you also post

cat /etc/modprobe.d/*
cat /etc/modules-load.d/*
cat /etc/mkinitcpio.conf | grep -E 'HOOKS|MODULES'

##
## Generated by mhwd - Manjaro Hardware Detection
##
 
blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm
install libnvdimm /usr/bin/ndctl load-keys ; /sbin/modprobe --ignore-install libnvdimm $CMDLINE_OPTS
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
nvidia
nvidia-drm
# List of modules to load at boot
# MODULES
#     MODULES=(piix ide_disk reiserfs)
MODULES=""
# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
##   This setup specifies all modules in the MODULES setting above.
#    HOOKS=(base)
#    HOOKS=(base udev autodetect block filesystems)
#    HOOKS=(base udev block filesystems)
#    HOOKS=(base udev block mdadm encrypt filesystems)
#    HOOKS=(base udev block lvm2 filesystems)
HOOKS="base udev autodetect modconf block keyboard keymap filesystems"

ok, theres a couple things you can try.

find the .conf file in /etc/modprobe.d/ that has these blacklisted and remove the following 2 lines
sudo nano /etc/modprobe.d/name-of file.conf

blacklist drm_kms_helper
blacklist drm

and add these 2 lines:

options nvidia-drm modeset=1 
options nvidia NVreg_UsePageAttributeTable=1

save/exit

also, edit /etc/X11/xorg.conf.d/90-mhwd.conf and add this line
Option “RegistryDwords” “PerfLevelSrc=0x2222” to the device section of nvidia like this:

sudo nano /etc/X11/xorg.conf.d/90-mhwd.conf

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
    Option "RegistryDwords" "PerfLevelSrc=0x2222"

EndSection

do some testing and see if it helps, there are other options too, read into these for more info
wiki.archlinux.org/index.php/NVIDIA/Tips_and_tricks
https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting
https://wiki.gentoo.org/wiki/NVidia/nvidia-drivers#Troubleshooting

I’ve tried all this but it’s still not working correctly. Maybe i should just wait for the next driver versions and check if everything is ok in the future.
But thank you for your help! I appreciate that!

1 Like

i would look into fixes that are specific to RTX on linux. hope it works out for ya.

Can you post the model of the mainboard ?

I have a MSI Z370 Gaming Edge

Can you check, if the graphics card is attached with PCIe x16 ?

You can see that in the UEFI Bios.

I think it definetly is. Because i use windows for gaming at the moment and everything is fine there with extreme high fps. and GPU-Z shows me x16 PCIe.

Hey (sorry, I only speak english, I read the thread with google translate) I’m having similar problems (see thread below) on my laptop which has an RTX 2060 on it. Ironically I had already switched full time to linux since september last year with a 980-Ti and I didn’t expect to have to go back to windows again, but now I’m reconsidering I guess.

Anyways, I just wanted to check whether or not we are having the exact same problem or not. So can you check 2 things for me?

1: Can you play a video (preferably hevc/h265) in mpv with this mpv.conf set? Does it stutter or run fine?
2: Is CS:GO playable? (Assuming you own it?) for me it had some stutters but overall it played just fine.

1 Like

Ah I solved my issue, disabling XFCE’s compositing made everything go from crappy and stuttery to silky smooth, try disabling your compositor.

1 Like

Forum kindly sponsored by Bytemark