Hiding The KDE Panel

I used to be able to hide the KDE panel using.

qdbus org.kde.plasmashell /PlasmaShell evaluateScript "panel = panelById(panelIds[0]); if (panel.height > 0) {panel.height = panel.height * -1;}";

and unhide it using

qdbus org.kde.plasmashell /PlasmaShell evaluateScript "panel = panelById(panelIds[0]); if (panel.height < 0) {panel.height = panel.height * -1;}";

This would allow me to use a Virtualbox VM in, what I call, psuedo Full Screen… where the window has been stripped of it’s Window decorations, and it is set to Max Vertical and Max Horizontl.

In this pseudo Full Screen mode I can still access my other virtual Workspaces, but without the KDE Panel suddenly popping up as it would if I had it set to Hidden of Windows Can Cover modes.

Unfortunately this script seems no longer to work, since Plasma 5.27. Instead the panel reduces to about half it’s normal size… about 11 pixels (I have it set to 22 Pixels)

my system

Operating System: Manjaro Linux 
KDE Plasma Version: 5.27.3
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 5.15.105-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Pentium® CPU N3540 @ 2.16GHz
Memory: 7.6 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics
Manufacturer: Notebook
Product Name: W54_W94_W955TU,-T,-C
System Version: Not Applicable

Have you tried with other values, like 0 ? (and then maybe your desired size for the other … 22 ?)

Yep tried zero, the panel is reduced to about 5 pixels. Negative values don’t work. Setting a Size doesn’t work.

I do believe I have solved the problem.

In System Settings → Work Space Behaviour → Screen Edges there are three check boxes at the top of the screen

Maximise Windows dragged to top edge

Tile Windows dragged to left or Right Edge

Behaviour Remain Active when Windows are Full Screen

This last one when checked seems to allow Windows to be Full screen (which is what I want for my VM Window) with the ability to switch to other desktops when desired.

If I remember correctly there was a similar option that made this possible on KDE3

With Behaviour option checked.

Ubuntu running Full Screen-resized

Ubuntu (in Work Space 8, bottom centre) running in a Window set to Full Screen.