hibernation login problem

Hi,

Sorry to bother you all, but I am having some problems with my Manjaro install, and need some advice and help.

I have some problems when the system comes out of hibernation and i try and log in.

The login screen is frozen after coming out of hibernation, the mouse pointer works and moves around, but I can't click on anything.

The user choice is locked to the last user logged in and there is no opportunity to select a different user. I can't select restart or anything else. The only way to switch users after hibernation is a hard reset of the computer system. More than one person uses this computer. The other person is my 81yr old windows 10 user mother who I am trying to seduce into using linux as her main computer.

The last user before hibernation hits, can log in to the system, but the blinker does not show up in the password field in the login box, and you don't see the dots appear that you usually see when you type in your password.

How do I fix this?

Also, I posted on this forum about another hibernation issue, under "power manager error". I don't know if that error message has anything to do with this login problem.

Power Manager
GDBus.Error:org.freedesktop.login1.SleepverbNotSupported: Not enough swap space for hibernation

image

I am still reading the wiki pages on arch and manjaro about how to do swap files to fix the hibernation problem, but it seems a little beyond my current knowledge and skill level as a linux newbie.

For example, to use Gparted to create a linux swap partition, I think I have to unmount the main drive to resize or create a new partition, but Gparted doesn't let me. I have a default ext4 931mb partition Manjaro XFCE 18.04 install on my system with 8gb RAM and 1TB HDD

Is the Gparted denial of my partition because I have the Manjaro linux system installed and running on that partition? If so, how do I unmount and partition the drive without doing a full reinstall? Any advice would be appreciated, as I am inexperienced with linux and out of ideas at the moment.

Once I fix the hibernation swap file problem, will this fix the login screen freeze problem too?

thanks and regards
Ed

Gparted won't let you resize the drive it's running on. It can't.
Use a Liveusb and use gparted from the liveusb to resize.

thanks SinisterBrain

I tried booting my live manjaro DVD, and using gparted, but that didn't work out. So i did a fresh clean reinstall of manjaro xfce 18.04 x86_64 stable and partitioned the drive with a swap file that way - this seemed to fix up the hibernation error message problem. I have since reinstalled and fixed all the initial problems i had on the old system, except for the hibernation login problem originally stated in this post.

The login screen coming out of hibernation still allows the mouse to move but not to click. I can't select an alternate user or do a restart (unless its a hard restart). And the password field still doesn't show up with dots when I type in the password.

Does anyone know how to fix this?

thanks and regards
Ed

This is by default. Use left click.

thanks banjo, but i have been using left click, still doesn't work

okay an update.

I figured out how to upgrade from 4.19.56-1-MANJARO x86_64 and install a new kernel 5.1.16-1 and restarted the system.

This fixed the problem with returning from hibernation and the screen freezing except for the mouse pointer and not being able to click or select alternate user or restart.

So, I guess it was a kernel problem then.

cheers
Ed

Randomly it happens to me.
I do ctrl+f4
Then enter login and password
Then type startx to restart the desktop

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.