Hibernating after a period of inactivity while asleep does not work


In KDE, there is an option to have the laptop hibernate after a few hours when it is on standby.

This used to work well before. I’m not sure what happened, but this doesn’t work anymore, probably after an update or something. My laptop frequently ends up running out of battery power completely as a result. Is there anything I can check?

A log would be nice.

Can you hibernate manually?

When I saw your post, I tried to do a hibernate… and I think I got a kernel panic (the caps lock LED kept blinking after a bit and nothing was happening). My laptop had been on for a few days by this point.

After rebooting, I tried a hibernate again and it worked.

Here’s a system log from 5 hours ago until now, during which my laptop has gone to sleep and back a few times. During this time I’ve also done the two hibernate attempts… though strangely I couldn’t find any traces of a kernel panic…

I am running kernel 5.15.94-1-MANJARO on a Dell XPS 13 9360.