Hibernate Not Working

After a fresh installation of manjaro i3wm and several hours on ricing, I found that hibernation is not working. But swap was correctly configured and hibernation was chosen when installing.

# lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
nvme0n1     259:0    0 476.9G  0 disk 
├─nvme0n1p1 259:1    0   300M  0 part /boot/efi
├─nvme0n1p2 259:2    0 460.1G  0 part /
└─nvme0n1p3 259:3    0  16.6G  0 part [SWAP]

# screenfetch
 ██████████████████  ████████     wwj@Manjaro
 ██████████████████  ████████     OS: Manjaro 20.1 Mikah
 ██████████████████  ████████     Kernel: x86_64 Linux 5.7.17-2-MANJARO
 ██████████████████  ████████     Uptime: 40m
 ████████            ████████     Packages: 1251
 ████████  ████████  ████████     Shell: fish 3.1.2
 ████████  ████████  ████████     Resolution: 3000x1920
 ████████  ████████  ████████     WM: i3
 ████████  ████████  ████████     GTK Theme: Adapta-Nokto-Eta-Maia [GTK2/3]
 ████████  ████████  ████████     Icon Theme: Papirus-Adapta-Nokto-Maia
 ████████  ████████  ████████     Font: Noto Sans 11
 ████████  ████████  ████████     Disk: 50G / 460G (12%)
 ████████  ████████  ████████     CPU: AMD Ryzen 5 4600U with Radeon Graphics @ 12x 2.1GHz
 ████████  ████████  ████████     GPU: AMD RENOIR (DRM 3.37.0, 5.7.17-2-MANJARO, LLVM 10.0.1)
                                  RAM: 3278MiB / 15435MiB


Any ideas?

BTW, I write a guide for ricing manjaro i3wm. If you are interested, see GitHub - Wangwj98/My-Manjaro-i3wm-Ricing. Thanks!

Hello,

check
grep HOOK /etc/mkinitcpio.conf if there is “resume” after “udev”
grep CMD /etc/default/grub if there is “resume=UUID=”

Hi, thanks for your reply. There is no “resume” after “udev”.
And the outputs are

~ grep HOOK /etc/mkinitcpio.conf
# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
#    HOOKS=(base)
#    HOOKS=(base udev autodetect block filesystems)
#    HOOKS=(base udev block filesystems)
#    HOOKS=(base udev block mdadm encrypt filesystems)
#    HOOKS=(base udev block lvm2 filesystems)
HOOKS="base udev autodetect modconf block keyboard keymap resume filesystems"
~ grep CMD /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=7f9d8fa3-6b87-4500-b99c-40b9743bf827 udev.log_priority=3"
GRUB_CMDLINE_LINUX=""
1 Like

I have no idea why, but this worked for me, anything else not:

HOOKS="base udev resume autodetect modconf block keyboard keymap mdadm_udev lvm2 filesystems fsck

Well well well.
Hibernation didn’t work yesterday night but it works now. Weird… And my touchpad not working problem is also auto-fixed.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.