Hi I have problem with shutdown

[pw@pw-systemproductname ~]$ export LANG=C
[pw@pw-systemproductname ~]$ inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.14.7-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64 
  root=UUID=31171dad-be92-43d7-ae86-2520cc770517 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: ASUSTeK model: Z170-E v: Rev 1.xx serial: <filter> 
  UEFI: American Megatrends v: 3801 date: 03/14/2018 
  Message: No system battery data found. Is one present? 
  RAM: total: 31.3 GiB used: 4.19 GiB (13.4%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i7-6700K bits: 64 type: MT MCP 
  arch: Skylake-S family: 6 model-id: 5E (94) stepping: 3 microcode: EA cache: 
  L2: 8 MiB bogomips: 64026 
  Speed: 2219 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 2219 2: 1588 
  3: 968 4: 800 5: 800 6: 800 7: 800 8: 799 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb erms est f16c flush_l1d 
  fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida 
  intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor 
  movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm 
  pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp 
  rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp 
  syscall tm tm2 tsc tsc_adjust tsc_deadline_timer vme x2apic xgetbv1 xsave 
  xsavec xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: TSX disabled 
  Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] vendor: Gigabyte driver: nvidia 
  v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1380 class-ID: 0300 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: nvidia display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 3440x1440 s-dpi: 109 s-size: 802x333mm (31.6x13.1") 
  s-diag: 868mm (34.2") 
  Monitor-1: HDMI-1 res: 3440x1440 dpi: 110 size: 797x334mm (31.4x13.1") 
  diag: 864mm (34") 
  OpenGL: renderer: NVIDIA GeForce GTX 750 Ti/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170 
  class-ID: 0403 
  Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX] 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
  chip-ID: 10de:0fbc class-ID: 0403 
  Sound Server-1: ALSA v: k5.14.7-2-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.37 running: yes 
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel 
  port: f000 bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200 
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-1: SEintegrity_vpn state: unknown speed: N/A duplex: N/A mac: N/A 
  IP v4: <filter> scope: global 
  IP v6: <filter> scope: global 
  WAN IP: <filter> 
  Message: No bluetooth data found. 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 717.29 GiB used: 72.35 GiB (10.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 750 EVO 250GB 
  size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 1B6Q scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SV300S37A120G 
  size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: BBF0 scheme: GPT 
  ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: HD403LJ size: 372.61 GiB 
  block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s type: N/A 
  serial: <filter> rev: 0-11 scheme: GPT 
  Optical-1: /dev/sr0 vendor: ASUS model: DRW-24F1MT rev: 1.00 
  dev-links: cdrom 
  Features: speed: 48 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw-size: 232.59 GiB size: 227.88 GiB (97.98%) 
  used: 43.62 GiB (19.1%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: 31171dad-be92-43d7-ae86-2520cc770517 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL 
  uuid: 438D-E6E9 
  ID-3: /run/media/pw/f1b86a83-538c-45e6-ae57-8d0f5d522b22 
  raw-size: 105.93 GiB size: 103.71 GiB (97.90%) used: 24 KiB (0.0%) fs: ext4 
  dev: /dev/sdb1 maj-min: 8:17 label: N/A 
  uuid: f1b86a83-538c-45e6-ae57-8d0f5d522b22 
  ID-4: /run/timeshift/backup raw-size: 372.61 GiB size: 372.61 GiB (100.00%) 
  used: 28.73 GiB (7.7%) fs: btrfs dev: /dev/sdc1 maj-min: 8:33 
  label: Timeshift uuid: 28d728b8-ad6a-4848-9b4e-48ed7f9337f8 
  Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 5.86 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdb2 maj-min: 8:18 label: N/A 
  uuid: d9f1c3f6-f58d-4cbe-97e9-fc195e9045dd 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-9:2 info: Wings Tech Taurus Mouse type: Mouse,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s 
  power: 480mA chip-ID: 2ea8:2203 class-ID: 0301 
  Device-2: 1-10:3 info: Logitech Illuminated Keyboard type: Keyboard,Mouse 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 300mA chip-ID: 046d:c318 class-ID: 0300 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 35.0 C mobo: N/A gpu: nvidia temp: 37 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 33% 
  Processes: 295 Uptime: 1h 5m wakeups: 0 Init: systemd v: 249 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: 1371 pacman: 1359 lib: 344 flatpak: 9 
  snap: 3 Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06 
[pw@pw-systemproductname ~]$ 

My computer will not shutdown properly. It says failed to start Wireguard via wg-quick for wg 0. I don’t know why Wireguard want to start when I try to shutdown computer. This happens about half of the time under shutdown. My config file is in etc/wireguard folder and I start with sudo wg-quick up /etc/wireguard/Seintegrity_vpn.conf and stop with sudo wg-quick down /etc/wireguard/Seintegrity_vpn.conf. Same result either I stop Wireguard or not. Recently learned reisub, comes to rei then computer shuts down, better than reset and start all over and then shut down but that always worked so far. Any suggestions?


Thank you I read that, my problem is not with the connection. My problem is computer shutdown.

Does the issue persist if you don’t use wireguard?

You will have go over your config - something in your config is causing this.

Frankly never tested that but when I reset my computer after failed shutdown then there is no wireguard connection and it always worked without problem to shut down then. The config file is downloaded from my IP provider and I don’t do any changes to it.

What I mean is

  1. Locate the point in time where your setup was working
  2. Retrace the modifications and changes until you reach the point where your setup begins to fail
  3. Then go over that specific change to locate the culprit.

You are the only person who can find it.

If you have a setting instructing the system to automatically reconnect on disconnect - the service could be misinterpreting the shutdown as a disconnect and try to reconnect instead of shutting down.

Now I don’t know it this is the cause - just an idea.

Well I understand. I had this problem with wireguard from the beginning when I installed Manjaro. I tried
different wireguard-tools wireguard-dkms wireguard VPN userspace etc. Now I only use wireguard-tools.
I’m new to Manjaro and always try to learn. I have 2 config files for different country, same problem with both. I have to try and find it out. I understand this is difficult I worked with this problem for nearly 2 months now. I tried to automatically reconnect on disconnect but it did not work, I always start manually. Yes I think your last point is correct the systemmisinterpreting the shutdown as a disconnect and try to reconnect instead of shutting down. I got plenty of time so I can live with it but it would be nice if I can fix it. I thank you for your suggestions and I also think you are right this is something I had to work on.

I think it works now. Maybe my IP provider change something in there server or for whatever reason it seams to work now. But nowadays I never forget to shut down my wireguard before shutdown the computer. :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.