Help with taskbar sound-control icon - third party icon

I am not sure if it is the right section for that post but I have a new theme with a small defect, the icon for the sound-control in the taskbar is wrong. Anybody knows where is the location of this icon in the icons theme ?

xfce right?

You can switch icon themes in : Menu > Settings > Appearance > Icons tab. Pamac can list various themes as well.
Also : $ pacman -Ss icon-theme

Maybe you don’t like it? :thinking:

Thanks but I know how to change icon themes. I am giving a hand to the developer to identify the bug. The sound-control icon is wrongly a crossed-circle. This is normally some sort of “speaker”. I want to find from where exactly the system get this icon from. Which folder in the icon theme structure contains that volume control icon.

This is what it looks like ;

The theme is Suru++ Asprómauros on xfce-look.org.

Usually that means the icon is not in the set or name is wrong.

I have check and there are plenty of sound-control icons with the correct icon in the theme but it is very possible the proper name is wrong. That is why I am trying to find what icon it is looking for.

The icon of the xfce4-pulseaudio plugin is not always the same, it corresponds to the volume level you have set. The name of the icon usually starts with audio-volume-* and has the string low/medium/high/muted depending on the volume level.

The icons are usually in the “status” sub-directory of the icon theme.

I just downloaded the icon theme you are using, copied it to /usr/share/icons, set it as default and the icon of the plugin is there. It scales when resizing the panel row size and changes when altering the volume level (low/medium/high/muted).

The Arch Wiki suggests an optional step for updating the icon cache when manually installing icon themes:

gtk-update-icon-cache -f -t path_to_directory_where_the_icon_folder_is_located/<theme_name>

Have you tried that?

After that you may need to restart the panel:

xfce4-panel -r

I hope that helps! :slightly_smiling_face:

Yes I notice the small warning triangle in the icon theme selection about the cache and did the update. I also did the panel reset but it is the same thing. I tried it also in virtualbox and idem.
So you are getting the proper icon ?

Btw all the others icons themes have the correct sound icon. The striken round icon here is the icon for “cancel” in the logoff/shutdown/suspend… box.

This is what I’m getting in the panel after setting the Suru++ Asprómauros icon theme as default:

sample-icons

As you can see, the icon for the xfce4-pulseaudio-plugin is there.

I noticed that you already reported this issue to the author of the icon theme on xfce-look[dot]org.
Hopefully he’ll find out what’s wrong.

Just noticed something strange, on my other computer which had Manjaro xfce installed a long time ago, it has 2 volume controls in the taskbar. One of them has the correct icon with that theme. It only has a simple vertical slider when you press on it and a list of outputs with a right clicking. The other one which has the problem is much more elaborated with two horizontal sliders (output-input control) and a bunch of players status. It is called “pavucontrol” in the properties. Not sure which one is the default control for Manjaro now.

Which one do you have ?

Btw the icons theme is fine on Mint xfce 19. I has the pavucontrol icon. weird

The plugin I have on the panel, with the icon as shown above, is called Xfce Pulseaudio Panel Plugin (or xfce4-pulseaudio-plugin). It’s one of the many panel plugins that were installed by default in Manjaro Xfce (at least when I installed Manjaro).

Did you install some other package for that purpose?

Try to add this plugin to the panel (if it’s not this one you already have), to see if the correct icon is displayed:
Right click on panel > Panel > Add new items > Scrool down until you find PulseAudio Plugin > click add.

Yes that’s the one I have. That’s the only one available to add to the panel. It is called “pulseaudio greffon” in French. I had an old snapshot of the first install on Manjaro XFCE 17.1.9 in virtualbox. That addon was there by default on install and the sound icon is still screwed by that theme.

So I have no idea how it works for you. Language thing ?

OK, let’s try something else. Create a backup of the folder of the icon theme (copy it somewhere else just in case) and try to rename the icon “audio-volume-high.svg” in the directory <theme_name>/status/16 to “audio-volume-high-panel.svg”.

After that restart the panel:

xfce4-panel -r

Does this make a difference to the panel icon?

EDIT:
Forgot to mention that the volume level has to be set to “high” in the panel plugin (nearly to 100% or something like that).

1 Like

Wow this thread is getting quite long for a simple icon problem.
Ok I install a brand new XFCE 17.1.10 machine in English in Virtualbox from a dvd. The icon is there but still get screwed by the theme.

  • I did what you ask and now read your edit, YES setting it to maximum get you the right icon ! You got it.

If that worked, than you should probably rename these icons in the same directory:

  • audio-volume-medium.svg > audio-volume-medium-panel.svg
  • audio-volume-low.svg > audio-volume-low-panel.svg
  • audio-volume-muted.svg > audio-volume-muted-panel.svg

and try to play around with the volume level of the panel plugin to see if the icon changes everytime you switch to low/medium/high/muted volume.

The thread got quite long as you said, but finally we worked it out and learned something along the way. That’s what’s important! :slightly_smiling_face:

1 Like

Damned, that works fine in my new Virtualbox machine but doesn’t work on my main computer (17.1.11)
I have check and double check, reset the panel, it just won’t works on the main one. Grrr. I’ll have to investigate.

If it’s not working on the computer you are referring to above, that is probably because you have conflicting packages leftover from your xfce install. In many cases you will have less issues by doing a clean install.

I just tried it on that second machine and it works fine there. It is just the main one.
There is months and months of work on my main machine, so no no re-install. I won’t reinstall for dawned icon. I’ll have to find it with your patch.

Have you installed multiple desktop environments, or switched DE’s on the machine that is currently giving you problems.

Ok tbg, I just wipe-out that icon theme from “/usr/share/icons” and copy a fresh copy back with the changes made before the copy. Fiouf, it is fine now !

Done ! Thank you very much for your help, especially @bill_t who didn’t let go. I will let the developer know about your changes. It seems that Mint doesn’t use those names (-panel).

2 Likes

@mariodesc and @bill_t

Thank you a lot for solving the problem. I was reviewing while you were quicker to solve the problem.

Merci beaucoup, Maurice !
Ευχαριστώ πολύ, Μπιλ!

Bill, can I credit you with your name and your username in the CHANGELOG?

1 Like

Forum kindly sponsored by