Help with pamac problem

I tried to run pamac update -a to update all packages, including AUR ones.
It tries to upgrade a package called gradle7 which I can’t remember to ever have installed, so I guess it came as a dependency somewhere. I noticed it’s an AUR package.

The problem is that the build of this package crashes and then the rest of the packages is not upgraded. So I decided I would remove that package and then upgrade the rest of the packages, worrying about any problems this would cause later when they occur.

But when I run pamac remove gradle7 I get the error target not found: gradle7. So this is strange, pamac wants to upgrade a package that is not installed?

Do you guys have any suggestion how to fix this, so that pamac does not try to upgrade a package that does not seem to exist on my system and fails all the time?

Don’t - unless you are prepared to solve issues.

gradle is a build automation tool which can be installed as a dependency for building a custom package.

When you encounter an attempt to update a package called gradle7 it may be caused by a nested dependency in an AUR recipe.

Using the inclusion of custom scripts with system update may or may not - most likely may - create unexplainable issues due to nested AUR recipes or deprecated packages.

Disable pamac’s configuration for automatic update of AUR recipes.

  1. First update your system
  2. Second rebuild your custom packages

Educate yourself reading below topics

Okay, I understand that. Thanks!
Your script also indicates that gradle7 and java11-openjfx need to be updated. I hope you know there are 2 small typos in your updated script?

The following line lacks closing quotes

echo "=> supported helpers:

And in the following line the d is missing in IgnoredPkgs

IFS=$'\n' ignored=("$(sort <<<"${IgnorePkgs[*]}")"); unset IFS

Meanwhile, I found that cleaning the pamac cache helped installing gradle7, so pamac clean.
Still have problems with upgrading java11-openjfx as the build eats up all my RAM. Again, I’m not sure why it is installed on my system, but this time I can uninstall it luckily.

thank you for spotting those - apparently I forgot to copy the content after my shellcheck.


1 Like