Help with "gpg: keyserver receive failed: No name"

Okay, so I am trying to install python35, however it comes up with this

“ERROR: One or more PGP signatures could not be verified!”

So I try to add the key with

“gpg --recv-key 3A5CA953F73C700D”

but this does not work. all that comes up is

“gpg: keyserver receive failed: No name”

I’ve been trying to figure this out for the past few days but I think I’ve reached my limit, if anyone could provide some help I would greatly appreciate it. If any more info is needed please ask.

The main keyserver that GnuPG has been using for a very long time, is no more.

So you need to change your ~/.gnupg/gpg.conf file to have:

keyserver hkps://

To have a working keyserver again, until the next upstream release of GnuPG fixes this.

PS: Add the same to /etc/pacman.d/gnupg/gpg.conf for pacman-key to also use the server.

1 Like

Thank you for the reply.

Sadly it didn’t seem to work. I am sure I am doing something wrong, I just don’t know what.

I used

“sudo pacman-key --refresh-keys -u --keyserver hkps://”

At the end it did report

“==> ERROR: A specified local key could not be updated from a keyserver.”

Which, maybe that isn’t important. So I tried installing pythone35 again and I get

“==> Verifying source file signatures with gpg…
Python-3.5.10.tar.xz … FAILED (unknown public key 3A5CA953F73C700D)
==> ERROR: One or more PGP signatures could not be verified!
Failed to build python35”

I try to add the key with

“gpg --recv-key 3A5CA953F73C700D”

but still get

“gpg: keyserver receive failed: No name”

Why can’t some things just work?

Installing AUR packages and using gpg to import keys, does not use the same keyring as pacman-key does.

What if you try: gpg --keyserver hkps:// --recv-key 3A5CA953F73C700D.

That does fetch the key for you?


That did the trick, thank you so much, I really appreciate it.

:fist_right: :fist_left: virtually and metaphorically implied fist bump.

There are actually a few programs I have been having trouble building because of this problem, like mullvad.

And again thank you.

I know you already got this working, but for a more long-term solution, check what Strit said you must do. If you get those errors, you haven’t properly add such line to those files.

gpg --keyserver --recv-key 3A5CA953F73C700D

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.