Help with first time install on an HP latop by a newbie.

Hi,

I've been playing around with this for quite a while now and am forced to admit defeat! I've searched both google and here for help and while there are 1001 potential-looking solutions all over the place, I haven't found anything that works for me yet.

I am trying to install official XFCE Manjaro 18.1.5 x64 on an HP ProBook 450 G1 laptop. I don't need to dual boot or have a fancy partition setup etc. The simpler the better to start with.

I booted with the live dvd and eventually got to the live desktop and hit 'install'. I selected 'erase everything', and the installer did its thing and all looked good until I rebooted and got:

BootDevice Not Found
Please install an operating system on your hard disk.
Hard Disk - (3F0)
F2 System Diagnostics

I googled this and sort of fixed it by booting the live dvd again and 'toggling the boot flag' using fdisk 'a' option (I think it was).

This would let boot get as far as grub, but grub would complain about unknown filesystem and dump me at a 'grub rescue' prompt. I googled that and tried a bunch of things such as 'set prefix=(hda0,msdos1)', 'insmod normal', 'normal' (or something like that) but still no joy. In grub rescue, I could 'ls' and see my single drive/partition, but I couldn't 'ls' that - I would get unknown filesystem.

I've tried another install from the live dvd, but same result. I had a good long look at the available install options there but there's not much you can change. I've tried some other things like creating a 'GPT' and creating a swap partition and main partition and installing to main but nothing's worked and I really have no idea what to do next.

Note: I am using 'Legacy' Boot Mode in BIOS. The other options available here are 'UEFI Hybrid (With CSM)' and 'UEFI Native (Without CSM)'. I'm kind of scared of messing with things here in case I ■■■■■ the laptop entirely - is this possible?

Any help would be greatly appreciated.

Bye!
Mark

ps: I don't know why b r i c k is getting changed to ■■■■■, I am trying to keep it clean here honest!

■■■■■ was added to the discourse filter when one of the mods got annoyed with people misusing the term. so now when something gets ■■■■■■■ you are ■■■■ ■■■■ out of ■■■■■. does that clarify things? :wink:

ok, back on topic.

since manjaro will be the only OS on the machine (right?), set it to either legacy or uefo only and no csm.

in bios, make sure the drive is set to AHCI and not raid or whatever. set to UEFI Only (or equivalent, no CSM). when you boot the usb, if there are 2 listings for the same usb drive pick the one labeled "UEFI". then install following the directions.

2 Likes

Use Etcher to burn LiveMedia to USB. Works great and is really easy to use.


Works every time.

Fixed!

I used 'rufus' to burn a USB stick (as per the excellent user guide pdf, which I only just found, rtfm etc) which is indeed much faster than a dvd!

I also changed the BIOS (?) boot mode settings from 'Legacy' to 'UEFI Native (No CSM)' and made sure secure boot was disabled (again as per user guide). Perhaps the user guide could mention that legacy mode might not work for some people?

This time when I went to install, there were less HD install options and a 300M EFI partition was created as well which was promising. It also installed very quickly and after a reboot I am now up and running Manjaro!

All in all, Manjaro looks fantastic IMO and, this little hiccup aside, turned out to be very easy to install. Congratulations to all involved and thanks for the help!

Bye!
Mark

1 Like

when legacy support is enabled the usb shows up as 2 devices in boot selection menu, if you chose UEFI it would install as UEFI, if you boot with the other listing without "UEFI" mentioned it installs as legacy.

some HP wont even boot anything other than windows if you install as UEFI because HP doesnt stick to uefi standards and puts the bootloader in a non-standard location so HP bios only looks for a bootloader in that location and ignores others. for that reason some people have to use legacy to avoid HP's bs they so freely distribute :wink:. anyway, glad to hear you got up and running. :+1:

1 Like

For an experiment I changed back to legacy mode and rebooted from USB. The 'BIOS' boot menu just showed one USB device, and after booting from this, the Manjaro boot menu appears:

Note there's nothing about UEFI or legacy in there, and there's also a 'notepad' type option without any description which looks wrong. I get this same boot screen whether I boot in legacy or UEFI mode.

Could I be doing something else wrong? Is there a way I can report this issue? I'd like to see Manjaro do well, but if everyone who tries to install in legacy mode hits the same problem I did, a lot of people could be being out off using Manjaro altogether.

There is nothing wrong as you have set BIOS as your firmware mode so no UEFI or BIOS option will appear when you boot of the LiveUSB. Depending on your hardware either select driver=free or driver=nonfree.

Just remember to make sure that bootloader is install on the right drive in your system and not the USB stick.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by