Help with emby and ntfs drives

Hello,

I installed emby with AUR but I have some questions.

As of now I always have to start the emby server withsudo systemctl start emby-server
It doesn’t start automatically. How can I fix this?

Also I have 3 external drives that are all ntfs. They mount do mount I can also read from and write to them outside of emby.
But when I want to add them as a location within the emby interface I can see them as /run/media/username/drivenamebut emby doesn’t allow me to add them. Do I need to mount them somehow?

sudo systemctl enable emby-server

start -> start de service
enable -> enable the service (then it start at boot)

2 Likes

sudo shouldn’t be necessary, systemctl asks for authentication.
Doesn’t matter in the end though.

1 Like

So when I use enable instead of start services start automatically?

yes, that enable the service to auto-start at boot

and about your ntfs problem.
yes I think you have to mount them with fstab

as when you mount them with the file manager. I think it heritate your rights as it’s in /run/media/username/ and amby-server run with an other user then certainly can’t access it.
and as the service will start at boot the ntfs drive won’t be mounted when it start if you don’t mount them at boot.
about how to had your ntfs partition in fstab I let you search

can’t give much more information as I don’t know amby-server

1 Like

Thank you. This was very helpful!

Emby is a great Media server. I just recently switched back to it, after trying one more time to get Plex to identify Music for more then a week. Any service any Linux can be started, stopped, enabled, disabled, status, and restart. You will have to enable most services you install to get them to start automatically. Or if you want to stop it from automatically starting just use sudo systemctl stop emby-server FOLLOWED by sudo systemctl disable emby-server. Or any service. Just be very careful it is a service you don’t absolutely need.

1 Like

Forgot to add that you will have to change permissions and/or ownership for Emby to work on Manjaro. Otherwise you will get an error that Emby can’t find your location. I normally add myself to the Emby group by sudo usermod -aG emby [myusername]. Then I change ownership of directory to allow Emby to see Media. My Media is stored at /mnt/Media so I change ownership by sudo chown -R emby:users /mnt/Media. Then change permissions so I can delete Media files from browser with sudo chmod -R 774 /mnt/Media. Although I am not positive about permissions and ownership on NTFS drives.

2 Likes

Yes that may be your problem. You may have to mount them in fstab with the proper ntfs permission settings.

1 Like

Yes you will have to mount them, but it sounds like they are being automounted by Manjaro. Manjaro and most of the other Arch-Based Linux will automount at /run/media/username/. This is easy to change. Or you can just leave it. To get emby to recognize or scrap your media all you have to do is change the ownership of those ntfs drives. So.

  1. sudo usermod -aG emby - I always add myself to any group that I am giving access to. You don’t have to, but it makes things easier sometimes.
  2. sudo chown -R emby:users /run/media/ - The sudo you will need to changed the ownership permissions, the chown is the command for change owner, and the -R means do it for the directory, all subdirectories, and all files. The emby is the user is now owns the directory, and users in the name of a groups that has access to the folder. chown :.
  3. sudo chmod -R 774 /run/media/. - chmod changes permissions for both the owner and any groups. 774 is pretty permissive, so you might want something more restrictive.

If you don’t want to use the command line you can also change ownership and permissions from within some file browsers. I know that thunar is capable of it.

You can install thunar by sudo pacman -S thunar. Or from your gui. Hope this helps.

I used a guide from plex to help learn about file permissions and ownership. Here is the link https://support.plex.tv/articles/200288596-linux-permissions-guide/.

I could be mistaken, but I’m pretty sure that procedure will not work for ntfs drives. For permissions to be changed, and for the permissions to be respected in Linux you must mount an NTFS drive via fstab using the dmask and fmask mount parameters.

This is an example of how you would want to accomplish this:

UUID=YOUR_UUID /mnt/YOUR_MOUNT ntfs-3g nofail,rw,user,uid=1000,gid=1000,dmask=022,fmask=133,permissions,noatime,windows_names 0 0

Do not modify your fstab file without researching the proper procedures first. Improperly modifying your fstab file can render your computer unbootable.

2 Likes

You are probably right. I have never used any NTFS drives since my Windows 7 decided that it needed a whole 1 TB of my external drive for a backup and locked me out of it, as it deleted my media. That is what prompted me to finally give up on Windows. I should have looked into it, before I gave him those procedures.

No, biggie your advice wouldn’t have broken anything. Bad fstab advice can really cause issues. No worries.

Yes, that is something else I had to learn the hard way. LOL
I am very impressed on how helpful people are on the Manjaro forum. Wish I would have tried this distro much sooner. Could have saved myself about 30 or 40 reinstalls of Antergos.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by