Help with A sound problem

i have a creative sound blaster Recon 3di the sound works through the speakers but when i plug headphones into my jacks nothing happens sound continues to come through the speakers is there anyway to fix this please. i'm fairly novice when it comes to linux i can follow step by step guides and instructions quite well

is the front panel headphone jack connected to the sound card ?
if headphone jack is connected to motherboard it can mute speakers connected to onboard audio
switching audio from sound card to onboard audio automatically might be possible, but may be limited by card features available

please post url link only from alsa-info.sh --upload for more information about audio devices

2 Likes

its a laptop i assume the jacks are build into the motherboard
http://alsa-project.org/db/?f=7023089f8fe4cfb38fb87d2510411e2793e5345e

apologies, I was expecting a pci-e card from that name

have seen laptops with Creative brand name mentioned, but is usually just a Realtek device (creative name may be only for windows software)
This has all the appearance of a Creative device in ALSA - CA0132
but also showing as an intel HDA device too
(alsa-tools for HDA devices should work for this)

There appears to be 2 settings in ALSA that affect headphones and speakers:

Simple mixer control 'HP/Speaker',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'HP/Speaker Auto Detect',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]

you should be able to locate controls with same names in alsamixer --card=0
use to locate 'HP/Speaker Auto Detect'
and or to change setting to 'on'

if it works to mute laptop speakers, save ALSA settings with sudo alsactl store

this laptop has 3 analog audio jacks and not all of them may may be able to mute speakers
audio playback to a 'Headphone' output is more likely to mute a 'speaker' output than another 'Speaker' output or 'Line-out'

1 Like

i will give it a try Thank you

i tried to change those two options in alsamixer using the up and down keys but it wouldn't change from off

if it is showing [MM] may need to use M to unmute it [OO]

1 Like

it was showing MM but only under those commands

OMG that worked Thank you so much i've been trying to figure this out for weeks

next problem is the Mic on my headset think we can get that working ?

this laptop has 4 jack sockets, so should be able to get a headset working one of 2 ways

headset with one TRRS jack should work if plugged in the 2nd jack from front of laptop
shown as item 13 on diagram in the user quick-start guide

OR headset could also be connected using a splitter cable to headphone jack (14) and microphone jack (12).
(could probably have 2 headsets connected at same time using all 3 jacks)

use F4 in alsamixer to switch to view of capture controls
and Space to turn capture devices on and off

might also need to look in Pulseaudio (pavucontrol) to find capture connections to headset or microphone jack

Forum kindly sponsored by