Help to identify why my system randomly and constantly freezes.

Hi,

First of all let me express my gratitude for your help.

I’ve been using Manjaro since September.

First I used the XFCE edition, but recently I’ve changed to Gnome edition.

In general, the system works like a charm, in both editions, the only thing is that sometimes it freezes and I have to poweroff via power button. The problem happens in both editions, it happens everyday, and sometimes even more than one time.

I’ve followed this thread I found in the forum:

By doing the following:

adding amdgpu.noretry=0 to your grub file (etc/default/grub at the end of the line: GRUB_CMDLINE_LINUX_DEFAULT=" default text amdgpu.noretry=0" then in console: sudo update-grub and restart).

Without success.

I’ve collected a couple of journal logs, but to be honest I don’t know how to analyse the files.

Some notes I’ve would like to add are:

  • I use Manjaro as daily environment for my work (software developer).

  • I use IntelliJ, Slack, VSCode and Docker. (I need to? Or I want to used them :joy:).

  • I have 3 extensions installed: clipboard indicator, screenshot and another to show system resources. The rest are the default that come with Manjaro.

I’m wondering who is causing the freezes!

Let me attach some data:

#################### lspci -vnn ########################

https://pastebin.com/sqdQhrha

#################### inxi -Fxzc0 ########################

https://pastebin.com/dMhBqPei

**System stopped at 17.30h

#################### journalctl -b -1 ########################

https://pastebin.com/VLQtZxjY

**System stopped at 12.29h

#################### journalctl -b -2 ########################

https://pastebin.com/qJftpaXV

If someone can give me any hint, it will be awesome.Thanks a lot.

Today I’ve had another freeze, but now when I log into the system it freezes in less than 5 minutes and I can’t do nothing. I mean, no tty2, nothing. I have to hard poweroff via power button.

What I’ve done is to log into tty2 and collect journal log to see what’s the problem, but to be honest I don’t know.
I did a photo, so if anybody can help…


Thanks in advance.

Can be slack desktop the troublemaker? Installed from aur, the bin. I’m asking because today I’ve tried with same hardware in different distro (Ubuntu based) and installed the .deb and after trying to connect to my workspace frozen computer.
After reboot I’ve been a while without opening slack,nit worked. Then I opened slack, and after some minutes… Frozen.

Then try to not use it for a very long period and see if that fixes your issue?

//EDIT: link the package you’re talking about because I can not find in the other anything else than this AUR (en) - slack-desktop

Yes, that’s the package.

I’ll do that.

Thanks for your time.