Help, new Linux user installed Manjaro and laptop boots to black screen

Hello, I’m new to Linux, and I probably should have learned more about this before I installed your product. I installed Manjaro XFCE on my HP Pavillion laptop with a Ryzen R7 processor (GPU: RX Vega 7), I and chose the assisted installation option of erasing the previous partitions rather than installing alongside the pre-installed Windows. Now my computer starts at a black screen, and I am not sure what to do. I tried some commands from other forums on your website and nothing seems to work for my situation. Please help.

We need more info than this.

Can you please boot into a LiveISO and provide:

inxi -Fza

The above command will provide us with more info about your computer, without revealing any personal identifying data.

Please put ``` before and after the output so that it is easier for us to read. You should be able to access the web browser in the LiveISO to post the output.

Also, notifying us what you did would help as well, so that we don’t make you try redundant things.

1 Like

I have a live version of the ISO on my flash drive, but I’m not sure how to access that from this black screen.

I am confused, you said you were able to install Manjaro XFCE

Which means you should be able to boot into the LiveISO without a black screen?

As soon as my computer rebooted after the installation, black screen. As far as I know, I am only able to access the non-graphical interface via CTRL+ALT+F3. I have logged into my account that I chose during installation, but I don’t know what to do after that. There might be an easy fix, I am brand new to Linux-based operating systems.

That’s why I am saying to boot into the LiveISO to obtain and provide the information we need, not to boot into your installation.

How am I to go about opening the the live .iso file? Is there a command that opens my boot-able files? I deleted Windows (the only way I knew how), and I am not able access the graphical interface of Manjaro.

I’m really at a loss here, I apologize. Deleting Windows was clearly a major mistake. If I can figure this out however, I’ll be sure to leave you guys a donation for the support.

You said you have the LiveISO on your flash drive.

When you start your computer, your BIOS should indicate at the bottom which F key to click to “boot from”, choose the USB stick. Or go into the BIOS and change the boot order, making the usb first

It should be the same way you booted into the LiveISO to install Manjaro in the first place… unless you did it some weird way

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  misobasedir=manjaro misolabel=MANJARO_XFCE_2021 quiet 
  systemd.show_status=1 apparmor=1 security=apparmor driver=free 
  nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: HP product: HP Pavilion Laptop 15-eh0xxx v: N/A 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 87C5 v: 35.23 serial: <filter> UEFI: AMI v: F.03 
  date: 08/10/2020 
Battery:
  ID-1: BAT0 charge: 40.6 Wh condition: 40.6/40.6 Wh (100%) volts: 12.9/11.3 
  model: Hewlett-Packard Primary type: Li-ion serial: N/A status: Full 
  cycles: 365 
CPU:
  Info: 8-Core model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64 
  type: MCP arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600104 L2 cache: 4 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 31959 
  Speed: 1397 MHz min/max: 1400/2000 MHz boost: enabled Core speeds (MHz): 
  1: 1397 2: 1397 3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 8: 1397 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel 
  bus ID: 04:00.0 chip ID: 1002:1636 
  Device-2: Luxvisions Innotech Limited HP Wide Vision HD Camera type: USB 
  driver: uvcvideo bus ID: 1-3:2 chip ID: 30c9:000e 
  Display: x11 server: X.Org 1.20.10 driver: amdgpu,ati 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: AMD RENOIR (DRM 3.39.0 5.9.16-1-MANJARO LLVM 11.0.0) 
  v: 4.6 Mesa 20.3.1 direct render: Yes 
Audio:
  Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
  bus ID: 04:00.1 chip ID: 1002:1637 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Hewlett-Packard driver: snd_rn_pci_acp3x v: kernel 
  alternate: snd_pci_acp3x bus ID: 04:00.5 chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 04:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus ID: 02:00.0 
  chip ID: 8086:2723 
  IF: wlo1 state: up mac: <filter> 
Drives:
  Local Storage: total: 491.84 GiB used: 104.9 MiB (0.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8H 
  size: 476.94 GiB block size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: HPS0 temp: 27.9 C 
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Memorex 
  model: Travel Drive CL size: 14.9 GiB block size: physical: 512 B 
  logical: 512 B serial: <filter> rev: PMAP 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition:
  ID-1: / raw size: N/A size: 11.3 GiB used: 104.9 MiB (0.9%) fs: overlay 
  source: ERR-102 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 51.9 C mobo: N/A gpu: amdgpu temp: 43.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 265 Uptime: 7m wakeups: 1173 Memory: 15.07 GiB 
  used: 1.73 GiB (11.5%) Init: systemd v: 247 Compilers: gcc: N/A Packages: 
  pacman: 1203 lib: 370 flatpak: 0 Shell: Bash v: 5.1.0 
  running in: xfce4-terminal inxi: 3.2.01```

Hello @Dth7 :wink:

First thing you can do is removing quiet from the boot parameter.

sudo nano /etc/default/grub

then remove quiet there and save it with CTRL+s and exit with CTRL+x.
Be sure you do this on another TTY on your local boot or when chrooting on a live session.

  1. chroot → manjaro-chroot -a on a live session should do this.
  2. TTY → CTRL+ALT+F3

and then do sudo update-grub. On next boot the boot process will be visible.

If everything is ok there… then it should be a xorg / gpu problem. Could be possible that it loads the wrong driver. To be sure please post this log here:

cat /var/log/Xorg.0.log

(Not from the live session, but from the local installation)

In general i would say, you have to add (amdgpu ati) to the /etc/mkinitcpio.conf at MODULES=, to be sure, it loads amdgpu first what the live session does. Maybe i am wrong…
After changing this file you have to run: sudo mkinitcpio -P

More information here:

https://wiki.archlinux.org/
https://wiki.manjaro.org/

1 Like

Thank you for helping sir. I did what you said: removed the word quiet from the file and updated the grub. I even refreshed mirrors, updated the system, and rebooted. Wait no I didn’t reboot…

Oh no, this made it worse. I can’t access the local terminals anymore with F2, F3, F4, F5, F6. Should I hard reset? Should I reinstall Manjaro? I need to get the working tonight or I will have to resort to buying Windows again. I prefer to keep this OS, I like it when I can get into the graphical interface. I want to learn more commands, but right now I just need a stable setup :dizzy_face:

I can add for sure that it says something like

acp_pdm_mach acp_pdm_mach.0: snd_soc_register_card(acp) failed: -

Twice on the screen right now.

Ok slow down…

To see where the problem lies we need the logs…

Chroot into the system (from a live session) and open terminal and copy paste this:

manjaro-chroot -a

then

journalctl --no-pager |  curl -F'file=@-' http://0x0.st

and

for x in $(ls /var/log/Xorg*); do echo -e "---$x---\n\n $(cat $x)\n"; done |  curl -F'file=@-' http://0x0.st

Keep sure you have internet access because it will upload the log and print a link on the terminal.

Then just post the links here.

This is just the soundcard…

I was finally able to get on and do the first command “cat /var/log/Xorg.0.log”, but now I have to leave for an appointment. I tried to put the responses in here, but now my laptop won’t connect to Wi-Fi for some reason, and embedding images from my phone don’t seem to work on this website… I will return later and troubleshoot.

Thats because you are new and didnt reach TrustLevel 1 where you can upload images and links. A link can be also posted as code with like this with 2 backticks:

`https://mylink.com`
:arrow_down_small:
https://mylink.com