Help I'm locked out of my Admin account after file system update!

The terminology is used in KDE Plasma in the user section and in Manjaro Settings Manager, we have two options for account type, Administrator or Standard.

Yes, that’s what you get when today’s GNU/Linux developers all grew up on Windows, Macs and smartphones. :grin:


@Max1 if you consider the problem still being there, the following information might help us understand the problem you are fighting with.
Please enter whoami In the terminal and ket us know what comes back.
As that us the user for which your automatic login is happening.
If another name than root is coming back your system is operating in the way most linux systems do with a regular user being logged in.

After that information, you could perhaps try to rephrase what isn’t actually working, I have read your comments a couple of times and don’t fully grasp what isn’t working. Originally I understood you as not being able to boot and log into your system, but that is apparently not the case.


I don’t think he’s logged in as root. If you enable auto-login in Calamares, it will do this for the first non-root user account created, but never for root.

1 Like

@Aragorn I don’t think he is either, but I’m trying to get this back to a problem solving track. This way we can be certain about the information instead of making assumptions (me) or very informed guesses (you).

While I understand why it happened, the responses got heated rather quickly. So I asked again for what is actually not working, being less experienced as most other responders here, I still struggle to understand what the problem actually occurring is versus the one we assuming to happen.
So let’s give him another opportunity to tell us what he is fighting with.

1 Like

Think I’m being hacked completely. Tried to log back into this site many times and the login system returns forgotten password even though i have input it correctly many times!!! Hope you can help i don’t know what to say first!!
Its taken me this long to get back in!!!

Not likely.

That might just be a browser setting, or a browser plugin that’s deleting your cookies.

So, as I gather then, the reboot has solved the problem, and you are now logged back into the account that you normally use?

Please confirm.

My standard account shows a nobody comment so i assuming that account does not exist. All i have and use is my Administrator account where i do all my updates and upgrades by just clicking add software from the lefthand menu or using the bottom right shield symbol for updates. This is the account i boot straight into. All i have to do is use a password thats all it takes for my updates to complete.
Hope you can help Merry Christmas to you all.

My PC Administrator password is not recognised anymore. I cannot complete any updates or upgrades anymore this has happened after i updated my file system package update.

The account nobody does exist, and it is a special system account that cannot be logged into. You should leave it alone.

If you type the following command in a terminal window, what does it say? :arrow_down:


Copy and paste the output here.

No – my Administrator password is not being recognised so i can complete updates or upgrades. This happened after i updated the file system package update.

This is Janet’s computer she is now 80 years old thats why we boot straight in!

Terminal is not letting me fully copy and paste but i managed to get this – uid=1000(janet1) gid=1001(janet1) groups=1001(janet1),3(sys),90(network),98(power),991(lp),998(wheel),1000(autologin)

  1. Is that your administrator account or the “standard” account (as you call it)?

  2. What happens when you type the following command? :arrow_down:

sudo su -

Its my administrator account. sudo su says – sudo password for janet1 (terminal is not allowing me to copy and paste!)

Are you using a newer version of Manjaro?

Is it accepting that password? Whether it does or doesn’t is important here.

I’ve installed this system in April 2019 and I’ve kept it updated ever since. Never had to reinstall.

Its very kind of you to help.
Its not accepting my password at all. I always update the PC regularily.

That may have happened! I don’t know where to start?

Does your password have any special characters? If you type your password into a text editor does it appear the way it should? I ask because you said there was a problem logging into the site as well, just want to verify nothing changed with your keyboard?

Okay, here’s what you can try…

If you still have the medium from which you installed Manjaro ─ I’m presuming it would be a USB stick ─ then shut down your system and reboot off of the USB stick in live mode. Once you see the desktop, open up a terminal window and issue the following commands… :arrow_down:

sudo su -
manjaro-chroot -a
passwd janet1

You will be prompted to set a new password. Remember that password ─ write it down if you must.

Now proceed with the following commands… :arrow_down:

pacman-mirrors -f 5 && pacman -Syyu

Let the update finish, no matter how long it takes. Then, issue the following commands… :arrow_down:

systemctl reboot

Remove the USB stick. After booting up in the installed system, open a terminal window and type the following command… :arrow_down:

sudo id

It’s just a silly command for which you don’t need sudo, but sudo will prompt you for a password. Use the password you have just set.

If it works, then the problem is solved. If not, then you’ve got a more serious issue there. :thinking:


Nothings changed i tried typing in the password with mousepad its all OK thanks :+1:

Will give it a try fingers crossed :crossed_fingers:

Hi your recommendation worked i’m back up and running with the new updates many thanks have a great Christmas :+1: :grin: