Help I'm locked out of my Admin account after file system update!

I’m locked out of my Admin account after a file system package update can any help i do have a Manjaro 21 live CD but have no clue with what to do with it?? Will that help me??

Hi @max1,

DO NOT PANIC! As you’re doing now.

First we need to know what is this “Admin account” you speak of?


Its my Administration account!!

Do you mean your regular account ─ in which you can use sudo ─ or do you mean the root account? Using the correct vocabulary is important. This is not Microsoft Windows, and the Windows terminology makes no sense here.

Also, the filesystem package could not have had any impact on your user account. So whatever did it must have been something else.

Have you rebooted yet?


Careful with filesystem package pacnew files: do not overwrite your systems /etc/passwd, /etc/group, /etc/fstab or /etc/shadow.


I use my administration account for everything i know its wrong. Here i just enter my password for updates. I tend not to use the Terminal although i have once or twice recently to check the updates were OK. If you look at the user accounts yourself theres standard accounts and Administration ones!!


calamares installer in manjaro uses the wrong terminology too then

Its been the same since the 80’s in all operating systems! I started using Linux since Ubuntu karmic 9. Was an old style Mac user beforehand!!

No, that’s not wrong, unless you are explicitly talking of the root account. You should never log into a GUI environment as root. But if you use your other account ─ which bears your name ─ then it’s all fine.

But so that’s what I needed to know: which account you are talking about.

Yes, it does. And as the matter of fact, if you choose the same password for both accounts, then the root account proper will be disabled in the same way as what Ubuntu and derivatives do.

Then you mustn’t have worked with too many operating systems. :wink:

Microsoft Windows has a system in which one or multiple user accounts have administrative privileges, and this was only introduced with Windows NT, because Windows 1.x, 2.x, 3.x, 95, 98 and ME all ran on top of DOS, which is a single-user operating system.

GNU/Linux on the other hand is a UNIX operating system, and in UNIX, there is a root account, which effectively has godlike permissions ─ root can write to everything ─ and then there are the regular user accounts.

A regular user account can elevate its privileges by way of su or sudo ─ or through the polkit framework ─ if it is in the wheel group, and today’s GNU/Linux developers call that “an administrative account”, but that’s just Windows terminology. It’s a regular account with the ability to elevate its privileges, but it doesn’t run with elevated privileges until it uses su or sudo, or when asked for a password via polkit.

1 Like

Why are you yelling? Even is you’re not, the way you speak, for lack of a better word, comes over as incredibly hostile.


So, concretely, you haven’t answered my question yet. Have you rebooted yet? If you have, then please describe what you are experiencing when trying to log in.

1 Like

I escaped Microsoft/shit as soon as i could i remember how much trouble the 98 updates were. Yet i still purchased a windows laptop recently and yes the updates are terribly slow on Virgin M100 speeds!!! :wink: yes i will use Linux on it too!!! Never had the doe for later Macs!!
It must be the root account I’m booting into and because i’m new to Manjaro and i have an elderly lady using this PC aswell and i thought booting straight into Linux Manjaro is or was safe anyway!!?
I’m wondering if i’m pushing the limits on how many characters or numbers i’m using for passwords???
Was on 18 adding one extra 19!!??

Not if you log in as root. But since you apparently don’t know what account you logged into, I am assuming that you had automatic login enabled? This allows you to log in automatically at boot time without entering a password.

Oh no ─ the more the merrier! :slight_smile: Short passwords are eevull. :stuck_out_tongue:

P.S.: The reason I am asking you all these questions is so that we would know exactly what the problem is and how to remedy it.

1 Like

I only have an Administrator account and a standard one. My brother is a Computer programmer!!! He will tell you using the administrator account is where you do the updates and upgrades!!

And would you be so kind as to tell us…

  • what those accounts are called on your system; …
  • (for the third time) whether you have already rebooted; and…
  • whether you can log into your “standard” account?

You’re not being very cooperative. :face_with_raised_eyebrow:

I did’nt want you to think i’m a newbie thats all!

I’ve tried rebooted a few times already thanks for asking. When i reboot it automatically logs me in!

I am being co-operative!!! i havent ever bothered booting into the standard account before but i will give it ago now

Then the problem is solved, no? :wink:


I will not interfere here, but a tip from me:
When you need help, when being asked a question. A short and precise answer to the question is what leads to solving your issue fastest.