Help fix manjaro grub screen after

Hi new manjaro forum i installed openSUSE on partition of extended but i didn’t put install of bootloader. somehow it made openSUSE as default. I can’t go into my manjaro anymore i don’t have the boot grub manjro screen anymore if sombody can help me please fix this step by step i would also like the same person on the other forum that helped me if you see this. Thank you

Hope this can help.
Good luck.

gohlip

I’m not understanding this step to get into manjaro

At that other linux grub menu, go into its grub prompt (grub>) by pressing 'c’
At its grub prompt,

grub> search.file /boot/intel-ucode.img root
grub> configfile /boot/grub/grub.cfg

All that i get is i press "C when openSUSE comes up right what do i do after

If you automatically boot to Suse without doing anything, that means you are already using Suse grub (otherwise Manjaro should boot up). If you don’t see a menu, that means Suse’s grub menu is hidden.

So if you do not see a menu, when computer starts up, keep tapping on ‘shift’ key. That should make Suse grub menu appear. If it don’t appear then when booted up to Suse, go to /etc/default/grub and comment out these lines to this

#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

And make this line

GRUB_TIMEOUT=15

At Suse’s terminal

sudo update-grub

Check if it is “sudo update-grub2” instead. (I don’t use Suse)
Then we will see Suse’s grub menu next time we boot.

Now…when Suse’s grub appear, either by tapping ‘shift’ or redoing it’s /etc/default/grub, press ‘c’.
You will see a grub prompt like this “grub>”

So now you can carry on with the commands

grub> search.file /boot/intel-ucode.img root
grub> configfile /boot/grub/grub.cfg

And do the rest when Manjaro boots up.

Thanks gohlip

Actually that’s not what i was talking about. I was confused on what to do with these commands

grub> search.file /boot/intel-ucode.img root
grub> configfile /boot/grub/grub.cfg

You have to type each one in when grub> comes up after pressing C

I thought i was finding those commands or something :smile:

You might want to add that in your tut

It worked flawlessly i have my manjaro grub and manjaro working and my MX-15 works all good now. I just have to try the openSUSE one its listed as unknown in grub and not openSUSE

openSUSE one its listed in GRUB as unknown. Is there a way to change it to openSUSE

I do not have openSuse, so I don not know why this is reported as unknown.
If people here has openSuse, your input (same unknown or listed properly) here may help LinuxTechy.

But there’s a few things we can work around this (may be unsatisfactory to you).

o Manually change the menuentry in grub.cfg to show "openSuse"
But remember that whenever there’s any “update-grub” it will revert to the “unknown” entry and the you will need to redo manually.

o Add an entry in custom.cfg and this will never be changed by any update-grub but there will be 2 entries for Suse;
one shown as the unknown and the custom one down at the bottom of grub menu.
And depending how you write the parameters, you will need to change this custom entry whenever there’s a new kernel change in Suse.
To do this, first create this custom.cfg and then put an entry there. That’s it. done.

sudo touch /boot/grub/custom.cfg
kdesu kate /boot/grub/custom.cfg

or gksu gedit /boot/grub/custom.cfg

Find out if there’s a sym-link generated by Suse to the latest kernel (most likely there is)
and let your parameter point to this sym-link instead of the actual kernel.
This sym-link may be in root / and not in boot /boot.
Then you won’t need to worry about changing anything in Manjaro grub when Suse updates kernel.

Without looking into it in detail (so I am not definite) and I don’t use any OS grub, most os-prober will looking into the OS 10_linux entry and use that as its menuentry for that OS.
It may (not sure) use what is in that OS /etc/lsb-release or other identifier to use in that os-prober.

So look into Suse 10-linux entry or lsb-release and maybe Suse use its own identifier so Manjaro’s os-prober does not find it.

As I said, I am not sure (and I am not too eager to find out :grin: ) what to me may be moot ( I don’t use any OS grub) and a minor detail. Just being honest here but hope you understand.

In fact, I disable all os-prober in all my OS (unless to test)

Just checked,
os-prober uses 10_linux which in turn uses os-release

So check if your openSuse uses /etc/os-release or still use old-style lsb-release
If there is no os-release, check if there is another os-release.new or os-release.rpm.new
Rename that to os-release, update-grub in Suse then update-grub in Manjaro.

What do you mean you don’t use os-prober. I didn’t use os-prober too. I just did what your tut said to do “update-grub” I don’t run os-prober no need to i don’t have windows installed.

normally i just do this. grub-mkconfig -o /boot/grub/grub.cfg

Its saying its using GRUB2 i think. Could i use grub customizer

You need os-prober to get all other OS’s into your grub menu. Without it, it won’t list other OS’s, windows or other OS’s including your Suse.

I don’t use os-prober because in my etc/default/grub, I disabled it with
GRUB_DISABLE_OS_PROBER=true
All my OS’s do not detect other OS’s then.
I don’t need it as I do not use any OS grub. I use my own grub.

grub-mkconfig -o /boot/grub/grub.cfg is the same as “update-grub”. Exactly the same. And it will run os-prober, unless disabled.

No. Do not use. It can really mess up things (in the future).

Do you have this, in Suse?

Important enough to ask this separately.
Do you have grub-customizer in Suse or anywhere?
Or had installed in the past (anywhere)?

NO i never used it before.

So manjaro has OS-prober auto on installed already is what you saying. On plan Arch it wouldn’t be there right. or wrong

All linux OS (AFAIK) has os-prober enabled by default, and should be.
And, as I said whenever we do ‘update-grub’ or ‘grub-mkconfig …’ it will be used, in all OS’s.

The point is not about os-prober itself but that it picks up other distro’s from their 10-linux entries which picks up from /etc/os-release.

So, go check your Suse /etc/os-release and go update-grub in Suse and then update-grub in Manjaro.
Have you done that?

ps: Is your Suse on grub-legacy?
And if on grub2, is directory in /boot/grub2/ rather than in /boot/grub?
But repeat, please don’t forget (again) to check Suse os-release.

I rechecked again - make sure you have lsb-release also in Suse.
File is /etc/lsb-release.
If not there, it will show as unknown

Thanks for explaining that to me i get it now :smile:

I will check openSuse and see

I checked and have this

LSB_VERSION="core-2.0-noarch:core-3.2-noarch:core-4.0-noarch:core-2.0-x86_64:core-3.2-x86_64:core-4.0-x86_64"
DISTRIB_ID="openSUSE Tumbleweed"
DISTRIB_RELEASE=“20160901"
DISTRIB_CODENAME=”"
DISTRIB_DESCRIPTION=“openSUSE Tumbleweed”

is that what you needed to see

And did you not do an “sudo update-grub” in your Manjaro terminal?

So I thought I’d show you.
I put in your lsb-release (exactly) in one of my Manjaro distros and did a “update-grub” in another Manjaro distro (os_prober enabled). It showed Suse as follows…

[pop@Nov ~]$ sudo update-grub
[sudo] password for pop: 
Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found Intel Microcode image
Found linux image: /boot/vmlinuz-manjaro
Found initrd image: /boot/initramfs-manjaro.img
Found linux image: /boot/vmlinuz-4.8-x86_64
Found initrd image: /boot/initramfs-4.8-x86_64.img
Found initrd fallback image: /boot/initramfs-4.8-x86_64-fallback.img
Found linux image: /boot/vmlinuz-4.7-x86_64
Found initrd image: /boot/initramfs-4.7-x86_64.img
Found initrd fallback image: /boot/initramfs-4.7-x86_64-fallback.img
Found linux image: /boot/vmlinuz-4.4-x86_64
Found initrd image: /boot/initramfs-4.4-x86_64.img
Found initrd fallback image: /boot/initramfs-4.4-x86_64-fallback.img                        
Found Bodhi Linux (16.04) on /dev/sda10                                                     
Found Ubuntu 16.04.1 LTS (16.04) on /dev/sda6                                               
Found Manjaro Linux (16.08) on /dev/sda7                                                    
Found Manjaro Linux (16.08) on /dev/sda8                                                    
Found Manjaro Linux (16.08) on /dev/sda9                                                    
Found Mageia 6 (6) on /dev/sdb2                                                             
[b]Found openSUSE Tumbleweed (20160901) on /dev/sdb7    [/b]                                   
Found Bodhi Linux (16.04) on /dev/sdc10                                                     
Found Manjaro Linux (16.08) on /dev/sdc12                                                   
Found Ubuntu 16.04.1 LTS (16.04) on /dev/sdc8                                               
Found Manjaro Linux (16.08) on /dev/sdc9                                                    
Found memtest86+ image: /boot/memtest86+/memtest.bin                                        
done
[pop@Nov ~]$ kdesu kate /boot/grub/grub.cfg

Found openSUSE Tumbleweed (20160901) on /dev/sdb7

In grub.cfg.

menuentry 'openSUSE Tumbleweed (20160901) (on /dev/sdb7)' --class opensusetumbleweed -

Couldn’t you get this?

Yes i told you i did “update-grub” That was the first thing i did

After doing this

grub> search.file /boot/intel-ucode.img root
grub> configfile /boot/grub/grub.cfg

Then i did “update-grub” after log in manjaro

How are you able to get it what are you doing that is working then me. Was i supposed to do something in openSuse before

Forum kindly sponsored by Bytemark