Headset's microphone is not detected by the system

realtek
audio
pulseaudio
alsa

#1

Note: Until I explicitly say that I have found a solution, I will always check for any new posts from this thread. If you have a solution, please let me know! Thanks!

Greetings!

I have gone through multiple places tonight on the virtual world of internet, however I am failed to find an issue that is similar to mine. The closest I can find on this forum is about the inverse of my situation.

Additionally I think it would be worth to add that I am not an expert, so I would really appreciate if the solution would be explained a little bit. I am here to learn

On to the issue
I have a pair of earphones (in-ear headphones) with a built-in microphone which is a Sony XB50AP. My laptop which is an Acer Aspire E series, has a single jack. When I plug the earphones in, and when I speak, the input meter only reacts to the internal microphone and not the earphones’.

Using pavucontrol, in the Port dropdown, only “Microphone” is listed, which is the internal microphone of my machine. Of course, the earphones work perfectly for output.

On Windows, I have a Realtek HD driver, also its own configurator which allows me to select what type of device I have connected. If I select “headset”, the microphone on the earphones works without any issue at all, while the internal one is disabled.

Is there any way I can do the same on Linux, either with automation or without? Also I will provide extra information if required.

Thank you!

System:    Host: TechnoLinux Kernel: 4.12.14-1-MANJARO x86_64 bits: 64 gcc: 7.2.0
           Desktop: Gnome 3.24.3 (Gtk 3.22.21) Distro: Manjaro Linux
Machine:   Device: laptop System: Acer product: Aspire E5-574G v: V1.08 serial: N/A
           Mobo: Acer model: Zoro_SL v: V1.08 serial: N/A UEFI: Insyde v: V1.08 date: 11/06/2015
Battery    BAT1: charge: 31.2 Wh 100.0% condition: 31.2/37.0 Wh (84%) model: SANYO AL15A32 status: Full
CPU:       Dual core Intel Core i5-6200U (-HT-MCP-) arch: Skylake rev.3 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9602
           clock speeds: max: 2700 MHz 1: 898 MHz 2: 892 MHz 3: 897 MHz 4: 891 MHz
Graphics:  Card-1: Intel HD Graphics 520 bus-ID: 00:02.0
           Card-2: NVIDIA GM108M [GeForce 940M] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.3 ) driver: nvidia Resolution: 1366x768@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           version: 4.5 Mesa 17.2.1 Direct Render: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.12.14-1-MANJARO
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8168 v: 8.044.02-NAPI port: 3000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: 54:ab:3a:1d:c5:73
           Card-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter driver: ath10k_pci bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: 30:52:cb:59:dc:2b
Drives:    HDD Total Size: 1000.2GB (23.5% used)
           ID-1: /dev/sda model: WDC_WD10JPVX size: 1000.2GB
Partition: ID-1: / size: 20G used: 16G (82%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 503G used: 204G (43%) fs: ext4 dev: /dev/sda6
Sensors:   System Temperatures: cpu: 50.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 235 Uptime: 55 min Memory: 3029.8/7854.3MB Init: systemd Gcc sys: 7.2.0
           Client: Shell (bash 4.4.121) inxi: 2.3.39 

#2

is your headset a dual jacked one?


#3

try checking alsamixer capture settings

use spacebar to turn capture off for built-in mic and enable front jack


#4

No, it is a single jack with 4 pins.


#5

I appreciate the reply, however the system never actually recognised that this pair of earphones has a microphone. So Capture settings will only show the built-in microphone. This is also the case in Pavucontrol and System Settings.


#6

Those 4 pole jacks (aka TRRS Jack) can be a real pain to get working right. suggest you get a usb microphone or headset instead

might be possible to use hdajackretask to turn off jack sensing and set up mic connection, but i wouldn’t expect it to work.


#8

I accidentally clicked on Delete post for the earlier post lel

I am interested to test that. This is actually kind of a huge bummer, since the headphones itself works on my Android phone the way they should.

I will delve into the hdajackretask as mentioned and will do some research.