Headset mic not detected in asrock A300

My pc is: ASRock > DeskMini A300 Series

  • 1 x Head Phone with Mic Jack
  • 1 x Mic-In
  • Realtek ALC233

Before upgrade Pulseaudio 14.0, there’s no problem with my headphone mic.
I’ve try to follow the arch wiki :Advanced Linux Sound Architecture - ArchWiki

Correctly detect microphone plugged in a 4-pin 3.5mm (TRRS) jack

On some modern laptops you may have a combined 3.5mm headset jack, instead of two separated ones, which may not be correctly detected by default. To make ALSA correctly detect plug-in status on your 3.5mm jack, you could put the following line into your /etc/modprobe.d/alsa-base.conf :

options snd_hda_intel index=0 model=[YOUR_MODEL_SETTING]

For a complete list of options to put in [YOUR_MODEL_SETTING] , see HD-Audio Codec-Specific Models. Tested with Gigabyte Aero15 2017 (P65 Model), with ALC255 and set model to dell-headset-multi .

But, I’m confuse, because there’s no /etc/modprobe.d/alsa-base.conf file in /etc/modprobe.d folder. Should I make a new file alsa-base.conf?
enter: options snd_hda_intel index=0 model=[headset-mic] ?

Any suggestion are welcome.

Thank you

That is the most logical step to take yes.
Because files under /etc/modprobe.d/ are meant to provide options to the modules loaded by the kernel.
So if you need extra options for whatever module, you are supposed to create config snippets in that directory :wink:
(The file-name does not matter, but the contents does)

OK, Thank you @TriMoon. I’ll try the next step. :slightly_smiling_face:

The solution is to buy a new audio splitter, as suggested by @bogdancovaciu in another thread.
Thank you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.