HDMI shows disconnected in xrandr

I'm fairly new to Linux. I am currently on Linux419 with running KDE Plasma5. I recently did a system update, and now my external monitor connected via HDMI is no longer working. I have another external monitor connected via DP and that one still works. I've switched HDMI cables and monitors to try and rule out a bad monitor/hdmi cable with no luck. I've also spent a great amount of time researching, but haven't found anything useful or that has worked.
Here's my xrandr output:

Screen 0: minimum 8 x 8, current 3840 x 1200, maximum 32767 x 32767
eDP1 connected primary 1920x1080+1920+120 (normal left inverted right x axis y axis) 310mm x 170mm
   1920x1080     60.00*+  59.93    48.00  
   1680x1050     59.88  
   1400x1050     59.98  
   1600x900      60.00    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1368x768      60.00    59.88    59.85  
   1280x800      59.81    59.91  
   1280x720      59.86    60.00    59.74  
   1024x768      60.00  
   1024x576      60.00    59.90    59.82  
   960x540       60.00    59.63    59.82  
   800x600       60.32    56.25  
   864x486       60.00    59.92    59.57  
   640x480       59.94  
   720x405       59.51    60.00    58.99  
   640x360       59.84    59.32    60.00  
DP1 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 520mm x 320mm
   1920x1200     59.95*+
   1920x1080     60.00    50.00    59.94    30.00    25.00    24.00    29.97    23.98  
   1920x1080i    60.00    50.00    59.94  
   1600x1200     60.00  
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Graphics info:

  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell Latitude E7470 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting 
  resolution: 1920x1080~60Hz, 1920x1200~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) 
  v: 4.5 Mesa 19.2.6 direct render: Yes 


Providers: number : 1
Provider 0: id: 0x47 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 4 associated providers: 0 name:Intel

Driver details:

                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

I tried to force re-install the driver to see if that would somehow fix it, but that didn't seem to resolve the issue.

Using a Dell Latitude E7470 64-bit machine with a Dell U2415 monitor connected via HDMI.

Not sure if I need to share any additional info.

  • Check relevant packages that were updated.

  • Try other kernels.

  • I regret to ask this, but with little info, we can't assume with confidence:

cat /var/log/Xorg.0.log

I was actually directed here where I found the solution: https://www.dell.com/community/Laptops-General-Read-Only/Latitude-E7240-HDMI-port-not-putting-out-signal-to-monitors/td-p/5181304
The issue seems to be unrelated to the update and doesn't seem to be a Linux/Manjaro or KDE Plasma specific issue. The HDMI port was not sending the signal to the monitor, I was able to resolve the issue by performing the following:

  1. Turn the laptop off
  2. disconnect every cable except the AC power adapter
  3. Open lid
  4. turn laptop on
  5. once into Manjaro, restart OS
  6. Turn monitor off
  7. disconnect HDMI from input
  8. reconnect HDMI cable to monitor input
  9. Turn monitor on
  10. reconnect HDMI to laptop HDMI out port
  11. Use display settings to extend Manjaro desktop.
1 Like

Great fix!!!!!
I bookmarked it!!!! :+1::rofl:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by