HDMI monitor not working

Hello,

I recently installed Manjaro KDE on my laptop, but my HDMI output is not working. I tried different cable and monitor, installing newest stable kernel (linux51) and updating everything (pacman -Syu), but none help. When I plug the cable in display options show up, but no matter which one I click, monitor screen does not show up.

My laptop is Lenovo Y530, processor Intel i7 8750H, GPU Nvidia 1050Ti.

Below is inxi -Fx output:

System:    Host: xxx-pc Kernel: 5.1.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           Desktop: KDE Plasma 5.16.2 Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81FV v: Lenovo Legion Y530-15ICH serial: <root required> 
           Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <root required> UEFI: LENOVO v: 8JCN23WW 
           date: 05/25/2018 
Battery:   ID-1: BAT0 charge: 38.0 Wh condition: 46.9/52.5 Wh (89%) model: SMP L17M3PG1 status: Discharging 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake rev: A 
           L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 53004 
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 
           7: 800 8: 800 9: 800 10: 800 11: 800 12: 801 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.5 driver: modesetting unloaded: intel resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.5 Mesa 19.1.1 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.1.15-1-MANJARO 
Network:   Device-1: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi v: kernel port: 5040 
           bus ID: 07:00.0 
           IF: wlp7s0 state: up mac: 30:24:32:41:1a:36 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8168 
           v: 8.047.01-NAPI port: 3000 bus ID: 08:00.0 
           IF: enp8s0 state: down mac: 8c:16:45:a0:2a:08 
Drives:    Local Storage: total: 1.78 TiB used: 10.36 GiB (0.6%) 
           ID-1: /dev/nvme0n1 vendor: A-Data model: SX8200NP size: 894.25 GiB 
           ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
Partition: ID-1: / size: 170.10 GiB used: 10.36 GiB (6.1%) fs: ext4 dev: /dev/nvme0n1p5 
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 265 Uptime: 40m Memory: 15.54 GiB used: 2.00 GiB (12.9%) Init: systemd Compilers: 
           gcc: 9.1.0 Shell: bash v: 5.0.7 inxi: 3.0.34

I would be thankful for any tips.

Could you post the output of mhwd -l -d --pci please.

Also, you might give this a read. :slight_smile:

2 Likes

Hello,

I think installing optimus-switch-gdm solved the problem. Thank you for your advice.

1 Like

I got another issue: when I boot Manjaro black screen appears and computer freezes and I am forced to reboot manually. I am 99% sure that this is optimus-switch-gdm related since I have not done any changes to system since I installed this switch. I tried to follow steps related to blank screen in related topic, but they did not help. Can you please provide me with tip to solve this issue? Thank you in advance.

Have you setup optimus-switch according to instructions?
In which mode is the system stuck?
Can you not switch to another mode from TTY?

@dglt will help you soon.

1 Like

after installing optimus-switch it was working and then a day later it was not working? does the black screen happen with intel mode? nvidia mode? both?

i need more info to know why this would happen, please post:
if you cant get past a black screen, use ctrl+alt+f2 to get to a tty and then
sudo set-intel.sh
systemctl reboot
this way you have a desktop to work from.

mhwd -li ; mhwd-kernel -li
pacman -Qs nvidia
ls -laR /etc/X11  
cat /etc/X11/xorg.conf.d/*.conf
cat /etc/modprobe.d/*.conf
cat /etc/modules-load.d/*.conf
cat /var/log/Xorg.0.log | grep -E "(EE)|(WW)|error|failed|Time"

which steps?

1 Like

Have you setup optimus-switch according to instructions?

I did according to instructions on this site: https://github.com/dglt1/optimus-switch-gdm

In which mode is the system stuck?

intel/nvidia prime

Can you not switch to another mode from TTY?

I can, by rebooting and running Manjaro in console mode.

does the black screen happen with intel mode? nvidia mode? both?

Both according to above github page.

Logs after the sudo set-intel.sh and systemctl reboot are below.
mhwd -li ; mhwd-kernel -li output:

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
          video-nvidia            2018.08.09               false            PCI
         network-r8168            2016.04.20                true            PCI


Warning: No installed USB configs!
Currently running: 5.1.16-1-MANJARO (linux51)
The following kernels are installed in your system:
   * linux419
   * linux51

pacman -Qs nvidia output:

local/lib32-libvdpau 1.2-1
    Nvidia VDPAU library
local/lib32-nvidia-utils 1:430.26-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.2-1
    Nvidia VDPAU library
local/linux419-nvidia 1:430.26-5 (linux419-extramodules)
    NVIDIA drivers for linux.
local/linux51-nvidia 1:430.26-7 (linux51-extramodules)
    NVIDIA drivers for linux.
local/mhwd-nvidia 1:430.26-1
    MHWD module-ids for nvidia 430.26
local/mhwd-nvidia-340xx 340.107-1
    MHWD module-ids for nvidia 340.107
local/mhwd-nvidia-390xx 390.116-1
    MHWD module-ids for nvidia 390.116
local/nvidia-utils 1:430.26-1
    NVIDIA drivers utilities

ls -laR /etc/X11 output:

/etc/X11:
total 32
drwxr-xr-x  5 root root 4096 03-12 10:39 .
drwxr-xr-x 92 root root 4096 07-13 16:56 ..
drwxr-xr-x  2 root root 4096 07-13 16:55 mhwd.d
drwxr-xr-x  3 root root 4096 03-12 10:40 xinit
drwxr-xr-x  2 root root 4096 07-13 16:55 xorg.conf.d

/etc/X11/mhwd.d:
total 12
drwxr-xr-x 2 root root 4096 07-13 16:55 .
drwxr-xr-x 5 root root 4096 03-12 10:39 ..

/etc/X11/xinit:
total 28
drwxr-xr-x 3 root root 4096 03-12 10:40 .
drwxr-xr-x 5 root root 4096 03-12 10:39 ..
-rw-r--r-- 1 root root  739 03-04 19:31 xinitrc
drwxr-xr-x 2 root root 4096 07-10 16:18 xinitrc.d
-rw-r--r-- 1 root root   45 03-04 19:31 xserverrc

/etc/X11/xinit/xinitrc.d:
total 20
drwxr-xr-x 2 root root 4096 07-10 16:18 .
drwxr-xr-x 3 root root 4096 03-12 10:40 ..
-rwxr-xr-x 1 root root  318 2018-11-09  40-libcanberra-gtk-module.sh
-rwxr-xr-x 1 root root  203 07-02 07:20 50-systemd-user.sh

/etc/X11/xorg.conf.d:
total 20
drwxr-xr-x 2 root root 4096 07-13 16:55 .
drwxr-xr-x 5 root root 4096 03-12 10:39 ..
-rw-r--r-- 1 root root  266 05-04 14:05 00-keyboard.conf
-rw-r--r-- 1 root root  672 07-13 16:55 99-intel.conf

cat /etc/X11/xorg.conf.d/*.conf output:

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "pl"
        Option "XkbModel" "pc105"
EndSection
# xorg configuration for use with intel driver.
# xf86-video-intel package required
#
# This driver now uses DRI3 as the default Direct Rendering
# Infrastructure. You can try falling back to DRI2 if you run
# into trouble. To do so, save a file with the following 
# content as /etc/X11/xorg.conf.d/20-intel.conf :
 
    Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "DRI" "3"             # DRI2 and DRI1 are alternatives if DRI3 performs performs poorly
        Option      "TearFree" "True"
        #Option      "AccelMethod"  "sna" # default
        #Option      "AccelMethod"  "uxa" # fallback
     EndSection


cat /etc/modprobe.d/*.conf output:

#blacklists all nouveau/nvidia modules
#so they are not loaded.

blacklist nouveau
blacklist ttm
install nvidia /bin/false
install nvidia-modeset /bin/false
install nvidia-drm /bin/false
install nvidia-uvm /bin/false

#######################################
#this following section can be removed#
#if you plan to use the modesetting   #
#driver intead of the intel driver    #
#######################################

#stops display from "blinking" or "flashing"
#during boot when using the intel driver.

options i915 enable_fbc=1
options i915 fastboot=1

blacklist r8169

cat /etc/modules-load.d/*.conf output:

# List of modules to load at boot

cat /var/log/Xorg.0.log | grep -E "(EE)|(WW)|error|failed|Time" output:

[     4.996] Current Operating System: Linux xxx-pc 5.1.16-1-MANJARO #1 SMP PREEMPT Thu Jul 4 20:32:22 UTC 2019 x86_64
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     4.996] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul 13 16:55:46 2019
[     5.001] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[     5.001] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[     5.001] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi".
[     5.002] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi".
[     5.024] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[     5.085] (II) Initializing extension MIT-SCREEN-SAVER
[     5.925] (EE) Failed to open authorization file "/var/run/sddm/{6435024b-94e4-4480-899f-51158fb063fc}": No such file or directory
[    51.158] (EE) event7  - SYNA2B46:00 06CB:CD5F Touchpad: kernel bug: Touch jump detected and discarded.

which steps?

These steps:

sudo systemctl disable bumblebeed --now
sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -r pci video-linux

if all that finishes without issue, continue on to these commands.

sudo mhwd -i pci video-nvidia
sudo pacman -S linux419-headers acpi_call-dkms xorg-xrandr xf86-video-intel git
sudo modprobe acpi_call

So far, I managed to run Manjaro in normal mode using sudo set-intel.sh and systemctl reboot, although HDMI port does not work in intel mode. Yet, if I do sudo set-nvidia.sh and systemctl reboot I cannot start Manjaro normally (only command mode). I switched back to intel, yet I think I would like to run in nvidia mode by default and have working HDMI port.

But you don't have gdm for DM, or do you?
You have Plasma and SDDM, so you need the SDDM version of the optimus-switch.
Configure sddm properly, by instructions.