HDMI doesn't turn off on blank screen


I use last Manjaro Gnome on my laptop MSI Leopard that uses external monitor connected with HDMI. I have a problem when screen is going blank - I see my cursor. And although my laptop is locked in some time - display stays on. I’ve searched such a problem in the google and here on forum but had nothing. What can you say?

Which screen goes blank? Your laptop screen or your monitor? And is there anything at all on the blank screen?

HDMI screen. It’s normal - but I expected it to turn off in a while. I also have Ubuntu on this laptop and HDMI display turns off after it become blank

If I’m correct, and your external monitor simply is black, but you can move your cursor around on it, it seems that this is a software problem, not a hardware problem. Try going to the Display Configuration menu in Manjaro Settings Manager and pressing Identify, then click on your external monitor (the one not labeled Laptop Screen), then make sure it’s settings are the exact same at the settings in the picture below:

Then press apply and restart your computer

I have another trouble ((( after recent update I got into infinite login loop. I can’t switch to console with Ctrl + Alt + F2. And also can’t login. It’s awful. Why system is so unstable)? It looked so polish and solid at first glance). How to fix this infinite loop? I found some links on this issue - but they don’t solve my problem. I tried to use usb stick and chroot into Manjaro but got failed. I see 2 systems 0 - Manjaro and 1 - Ubuntu
and can’t switch into Manjaro ((


What does the screen show on the login loop? Is it a black screen with some text in the top left corner? Or is it something else?

Could you take a picture/video and submit it here?

Yes it looks like normal login. I entered correct login / password then system tries to show desktop and tnan “redirects” me to login page again. I tried to entered wrong password - it shows expected message with wrong passsword. I’ll attached video

I can’t download videos or paste links to my google drive

By any chance did you enter a separate login password from your master password?

Do you mean some wrong password to check? If yes - I did and I got an appropriate error