Having trouble with my first Manjaro installation (after several years of Arch) and I think it has to do with network/wifi

After having used Arch (i3) for years, accepting that I wasn’t able to configure some stuff (because I didn’t care and didn’t want to invest all the time investigating it), I came to a point where I started noticing that there were even important things I didn’t configure correctly. Battery life on my laptop was always very short and I never bothered configuring the dual gpu system correctly, just always using the dgpu.

So several days ago, I made the switch to Manjaro (i3), thinking that all basic configuration I had troubles with before were installed and configured for me. And it seems like that is the case. I thank all the contributors.

But I am having issues I didn’t have with my Arch installation, and I guess that that also has to do with configuration that Manjaro made for me. I used NetworkManager on my Arch and it comes installed with the i3 version of Manjaro. This time, however, the NetworkManager applet keeps hanging for up to 3 minutes (while wifi is already working fine), blocking itself (can’t select the VPN of my work for example).

Sometimes, my whole system starts slowing down. My mouse stops moving for 3 seconds, then it works for a split second, then it stops moving for 10 seconds, then moves again for a split second and then my computer seems to hang forever and only resetting is the solution. It usually comes when I am starting up network traffic (after playing a game on Steam → save file sync, and just now when I started the download of a game on Steam). Maybe it has nothing to do with NetworkManager/wifi, but I guess it does. I didn’t have these things with my Arch installations and I must have been using the driver that I have now on it as Manjaro’s version will most likely be one I have used on Arch before.

Any clues? What logs can I investigate?

The laptop is a BTO X-BOOK, intel i9 5Ghz, 32Gb memory, Intel GPU + Nvidia RTX2070, 4K OLED screen. It’s a beast :wink:

I’m sure you heard the saying Achilles’ heel … well, everything has a blind spot or something that can drag it down.
You described a couple of situations that might be good as correlation of issues, but not exactly pointing to the cause of such correlated or not issues.
inxi -Fxza --no-host
Usually gives us a better idea of the system we talk about.

You can straight forward try to disable mac address randomization of wifi, disable IPv6 … and you can replace NetworkManager with connman (this is recommended on some special cases even tho there is no disadvantage doing it anyway).

Hi, thanks,

$ inxi -Fxza --no-host
System:    Kernel: 5.7.17-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 root=UUID=cb228593-fb2d-4c1c-a880-e367b59b83df rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 acpi_osi=! acpi_osi=Linux 
           Desktop: i3 4.18.2 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Notebook product: PB50_70RF,RD,RC v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Notebook model: PB50_70RF,RD,RC serial: <filter> UEFI: INSYDE v: 1.07.13 date: 02/01/2019 
Battery:   ID-1: BAT0 charge: 58.8 Wh condition: 58.8/62.1 Wh (95%) volts: 12.5/10.9 model: Notebook BAT type: Li-ion 
           serial: <filter> status: Full 
CPU:       Topology: 8-Core model: Intel Core i9-9980HK bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: D (13) microcode: D6 L2 cache: 16.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 76816 
           Speed: 900 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 5: 900 6: 901 7: 900 8: 900 
           9: 900 10: 900 11: 900 12: 900 13: 900 14: 900 15: 900 16: 900 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: srbds mitigation: TSX disabled 
           Type: tsx_async_abort mitigation: TSX disabled 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: CLEVO/KAPOK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA TU106M [GeForce RTX 2070 Mobile] vendor: CLEVO/KAPOK driver: nvidia v: 450.66 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1f10 
           Device-3: Acer BisonCam NB Pro type: USB driver: uvcvideo bus ID: 1-9:6 chip ID: 5986:9102 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: intel,nouveau alternate: fbdev,nv,vesa 
           display ID: :0 screens: 1 
           Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.0x22.5") s-diag: 1165mm (45.9") 
           Monitor-1: eDP-1 res: 3840x2160 hz: 60 dpi: 284 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.6 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:a348 
           Sound Server: ALSA v: k5.7.17-2-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK driver: r8169 v: kernel 
           port: 3000 bus ID: 72:00.0 chip ID: 10ec:8168 
           IF: enp114s0 state: down mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 3000 bus ID: 74:00.0 chip ID: 8086:2723 
           IF: wlp116s0 state: up mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 718.12 GiB (77.1%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 2B2QEXE7 scheme: GPT 
           ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 2B2QEXE7 scheme: GPT 
Partition: ID-1: / raw size: 674.91 GiB size: 663.32 GiB (98.28%) used: 22.83 GiB (3.4%) fs: ext4 dev: /dev/nvme0n1p5 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 70.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 293 Uptime: 12m Memory: 31.08 GiB used: 2.17 GiB (7.0%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           Packages: pacman: 1415 lib: 419 Shell: Bash v: 5.0.18 running in: terminator inxi: 3.1.057

That’s a nice command!

I’ve disable IPv6 on the wifi connection, that is of course only on this specific connection, so can I disable it for every connection?
I don’t know how to disable mac randomization. The only thing I can see in the settings is ‘Cloned MAC address’ and it is empty.

FYI: The kernel parameters acpi_osi=! acpi_osi=Linux are for the backlight controls for my keyboard, otherwise the room is fully lit in blue and I can’t disable it. I found these somewhere on the internet and it ‘just worked’.

See this:

Not sure why

maybe you can add also nouveau.modeset=0 together with

Done… done and done… Thanks, I’m learning already.
I rebooted but sadly, the problem is still there.

Edit: I don’t know if it’s related but I’m saying it just in case: sometimes Firefox may hang for 20 seconds and also xrandr can take up to 10 seconds to react. Both mostly work fine. I use xrandr to change the brightness & gamma on the OLED screen from a self-made python script. It worked fine on my Arch installation, but on this installation, when I start it by using the Fn-keys for brightness, it sometimes hangs for several seconds. After that it works fine for minutes and then it has this again.

You shouldn’t have issues on Manjaro you don’t have on Arch.

That said - when you are used to Arch - I highly recommend switching to what in Manjaro world is know as unstable branch.

That is the closest to Arch you will get while being on Manjaro.

sudo pacman-mirrors --continent -aS unstable && sudo pacman -Syyu

NetworkManager has been bugging me lately but that is the same whether on Arch or Manjaro. Sometimes network doesn’t come up at boot and nm-applet tray is telling me networkmanager is not running.

It usuallly appears after updates but otherwise without clues. Starting networkmanager manually usually solves the issue.

No clue. Have you tried this ?

Do you have haveged installed and the system enabled/started? Might help.

Hi, no, the main reason I switched to Manjaro is exactly for the availability stable branch. I use Linux on my work laptop too and every week there is at least one (small or big) problem with the unstable software on Arch that causes problem for my work. Last two weeks it was Virtualbox not being compatible with the latest kernel and I really needed to build, test and certify an executable of my software on the Windows VM.

1 Like

Yes, I have tried icc-brightness. I can’t get it to work on i3 (did work for xfce) but it is also very sluggish and stuttery. I don’t like how it works. My script is also much simpler, not ready for the public though: arch_bto_15x990/brightness.py at master · scippie75/arch_bto_15x990 · GitHub

Installed it. Didn’t know about it.

You also have to enable the service.
systemctl enable haveged --now
otherwise i don’t think the unit will start.

I already did but thanks for reminding me :slight_smile:

Sadly, haveged didn’t seem to help.

I might try this connman then, but one of the reasons I like NetworkManager is that it has a plugin for Fortinet VPN which I definitely need for my work. I will have to investigate how that works in connman.

Ok, I just tried connman (disabled/stopped NetworkManager, rebooted to be sure) and I had the same issues. As soon as I started cmst to configure the wifi, its window popped up and then it all hung, never reaching the point where I could actually connect to something.

The problem seems to be rooted deeper than the network manager.

Just tested it, when I click on the NetworkManager tray icon, it takes 45 seconds for something to show up. I think that it hangs every time it refreshes the list of AP’s, and the same is probably happening with connman.

The plot thickens…

I just enabled pulseaudio and installed pa-applet for the tray icon. Loading the tray icon also seems to take forever and pulseaudio won’t work after boot. Pavucontrol will say it is searching for the pulseaudio server. But ps tells me it is running. Only if I kill it and restart it, pulseaudio will work.

When I then use the volume controls (I disabled them in my i3 configuration because pa-applet takes them over), it may again take up to 1 minute!!! before the volume changes (so it actually works).

It looks like something on my system is blocking events until some timeout happens. I guess this may no longer be a network issue but something deeper. Is there something I can check? Can I see if things are being deadlocked, stalled, whatever on a very low level?

Solved one thing: the xrandr slowness seems to be solved by downgrading to the nvidia 440 driver.

But the most important issue is still there. Anyone? Please?

Maybe try and install manjaro via architect, which gives you more ‘freedom of choice’, and trying to stay as close to your arch installations as possible :thinking:

It sounds like some sort of I/O write and writeback issue, either to RAM or Disk. If it’s RAM then your swappiness might be set too high. If it’s to Disk then it could indicate a hardware problem.

swappiness is in /proc/sys/vm/swappiness. If it’s 60 lower it to 10. The I/O disk thing I’m unsure how to check or rectify that but htop or glances might show something. htop should be installed, glances probably not but it’s available.

I’m not sure if the above info shows the right place to look (I’m no expert user/guru!) but it may give some insights. Hope it’s helpful, good luck :smile:

I don’t use a swap disk, doesn’t seem necessary with 32GB memory and it has always worked fine without swap disk for me. Still though, I will try and set is lower. I hope the system isn’t trying to swap out memory just to discover that it doesn’t work… Setting it to 10 doesn’t seem to help.

The disks are around 6 months old and worked fine with other osses on it. I’ll check the SMART status to be sure, but I really doubt that would be the case. I have 10 year old Samsung SSD’s that still work fantastic. Smart checks say the disks are fine.

Hmm…As you said: the plot thickens… :man_shrugging:

Hopefully some wise sage is reading this thread and can shed some light. I’m intrigued so I’ll keep tracking it while I do a bit of research.

1 Like