Having trouble with Discord under Trizen


#1

I know Discord isn’t open source but I do use it for gaming with other Linux users. Here is what my Terminal says:

$ trizen -S discord
HEAD is now at 4970eda add noto-fonts-cjk optdep
Already up to date.

:: Package: discord
:: AUR URL: https://aur.archlinux.org/packages.php?ID=539578
...
==> Making package: libc++ 6.0.1-1 (Mon 03 Sep 2018 03:07:01 PM CDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found llvm-6.0.1.src.tar.xz
  -> Found llvm-6.0.1.src.tar.xz.sig
  -> Found libcxx-6.0.1.src.tar.xz
  -> Found libcxx-6.0.1.src.tar.xz.sig
  -> Found libcxxabi-6.0.1.src.tar.xz
  -> Found libcxxabi-6.0.1.src.tar.xz.sig
==> Validating source files with sha512sums...
    llvm-6.0.1.src.tar.xz ... Passed
    llvm-6.0.1.src.tar.xz.sig ... Skipped
    libcxx-6.0.1.src.tar.xz ... Passed
    libcxx-6.0.1.src.tar.xz.sig ... Skipped
    libcxxabi-6.0.1.src.tar.xz ... Passed
    libcxxabi-6.0.1.src.tar.xz.sig ... Skipped
==> Verifying source file signatures with gpg...
    llvm-6.0.1.src.tar.xz ... FAILED (unknown public key A2C794A986419D8A)
    libcxx-6.0.1.src.tar.xz ... FAILED (unknown public key A2C794A986419D8A)
    libcxxabi-6.0.1.src.tar.xz ... FAILED (unknown public key A2C794A986419D8A)
==> ERROR: One or more PGP signatures could not be verified!
:: Unable to build libc++abi - makepkg exited with code: 1
=>> Do you want to try again? [y/N]: 
=>> Do you want to exit now? [Y/n]:

I said no to all editing and just told it to install it. I used to use Yaourt but I got told it was not being supported and it’s been a long time since I used Manjaro.

I tried using snaps and got this error:

[lamer@Thinkpad-T430 ~]$ sudo snap install discord
[sudo] password for lamer: 
error: cannot communicate with server: Post http://localhost/v2/snaps/discord: dial unix /run/snapd.socket: connect: no such file or directory

#2

Please use </> code tag to enclose output - its much easier to read that way.
Actually, with output this big its best to use something like pastebin to host the text.

Anyways … your error is this one:

ERROR: One or more PGP signatures could not be verified!

stemming from these:

llvm-6.0.1.src.tar.xz … FAILED (unknown public key A2C794A986419D8A)
libcxx-6.0.1.src.tar.xz … FAILED (unknown public key A2C794A986419D8A)
libcxxabi-6.0.1.src.tar.xz … FAILED (unknown public key A2C794A986419D8A)

Please see the wiki or or use the search function of the forum to resolve this common issue.
It is not a problem with the package - you simply need to import the needed key.

AUR package fails to verify PGP/GPG key: "One or more PGP signatures could not be verified!"


#3

Alright thank you and sorry about that I’m new to the forums and I saw that mess up there and wishing I knew that. Sorry again


#4

You are forgiven :woman_judge: :stuck_out_tongue_winking_eye:


closed #5

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.