Having difficulty mounting an SMB share correctly

I’m in a situation where I need to mount a share on an off-the-shelf consumer NAS device. The only protocol it supports is CIFS (aka SMB1) - which was already outdated 5-10 years before this device was built, so I’ve no idea why they used that, but I digress.

I added it to fstab as follows. Imagine device is the hostname of the NAS device, and “me” is both the name of the share and my username on the device. Apologies for this being interpereted as a comment in the forum software; I have no idea how to turn that off.

//device.local/me /media/me/ME_ON_DEVICE cifs username=me,vers=1.0,noauto,rw,users,_netdev 0 0

I should now be able to execute mount /media/me/ME_ON_DEVICE, enter my password and have access to the share.

Initially this appears to work - I can list the files on the share and read individual files off it. The problem comes when I try to copy multiple files from the share to my Documents folder.

  • In Nemo (a graphical file manager), it gets stuck showing a certain percentage copied and the cancel button does nothing when clicked
  • In Thunar (another graphical file manager), it gets stuck showing “Collecting Files” and the cancel button doesn’t work
  • Using cp from the command line, it happily copies some files and then just hangs

I’ve tried adding UID and GID properties to the fstab entry and it made no difference. I tried booting from a different kernel version and it didn’t solve the issue (though interestingly it did cause it to get stuck at different files to on the original one). I also tried connecting by entering smb://device.local/me into the address bar of Nemo and Thunar - it asks for my password and then never accepts it even if it is entered correctly.

Any ideas what’s going on?

Have you tried to just manually connecting the network drive in Thunar? Just to ensure the same problem occurs then as well.
I had some problems automounting my NAS, but it always worked via Thunar. I think my fstab solution is very similar to ours and that works fine after i finally got it tweaked.

Hi @py-mpixel ,

Please see [root tip] Use systemd to mount ANY device

And then [root tip] systemd mount unit samples

Could you please give your nas name and specification.
Then, provide us your exact fstab entry related to your mount.
Finally, give us your error messages you get in journalctl or elsewhere

Hi, sorry all for the delay in responding to you

@yannssolo - I have already provided the complete fstab entry in the first post. The NAS is a D-Link ShareCenter; I don’t know the exact model and it doesn’t appear to be written on the thing anywhere

@Mirdarthos - I can’t mount it at boot as it is not always online. I need to be able to mount it manually with a command.

@Alchemix - Yes, I’ve already tried that. I don’t get the same problem, I get a different one - it won’t accept my credentials even if I enter them correctly. There is no error message; the window asking for username/password simply vanishes and reappears after a second or two, and no connection is made.


Look at those again. What you want is an automount unit. There is wn example of that there, too.